Kingsoft Spreadsheets 2016

Kingsoft Spreadsheets is a flexible and efficient commercial application. It is widely used by professionals in many fields such as business, finance, economics, and so on. It features calculation, graphing tools, and many other tools for complex data analysis. Kingsoft Spreadsheets supports more than 100 commonly used formulas and has a battery of supplied functions (e.g. conditional expressions, sorting, filtering and consolidating) to make it much more convenient to analyze data. Meanwhile, the Conditional Formatting now supports more than 3 simultaneous conditions, adding rules such as Data Bars, Color Scales, and Icon Sets, which will greatly improve work efficiency.

Kingsoft Spreadsheets has a variety of spreadsheets templates that allow the users to create all kinds of spreadsheets easily and efficiently. And its Functions have been localized to Russian, German, French, Spanish, Portuguese, and Brazilian Portuguese. Kingsoft Spreadsheets is completely compatible with all Microsoft Excel files and is also capable of displaying other file formats such as txt., csv., dbf. xltm ,xltx etc.
# Table of Contents

1 Kingsoft Spreadsheets Basic Operation............................................................................................................. 1

1.1 Brief Introduction.................................................................................................................................................. 1

1.2 Kingsoft Spreadsheets Interface....................................................................................................................... 1

1.3 Basic Operations.................................................................................................................................................. 2
  1.3.1 Operations in Cells ................................................................................................................................... 2
  1.3.2 Multiple summary results in the status bar............................................................................................... 3
  1.3.3 Smart Contraction .................................................................................................................................... 4
  1.3.4 AutoComplete Function............................................................................................................................ 5
  1.3.5 Switching Skins.......................................................................................................................................... 6
  1.3.6 Activating Kingsoft Office......................................................................................................................... 7
  1.3.7 Switching Among Multiple Files by the Unique Tab Feature................................................................. 8
  1.3.8 Hiding and Showing the Toolbar............................................................................................................... 10

1.4 The Application Menu....................................................................................................................................... 11
  1.4.1 The New Option in the Application Menu.............................................................................................. 11
  1.4.2 The Open Option in the Application Menu............................................................................................. 13
  1.4.3 The Save Option in the Application Menu.............................................................................................. 14
  1.4.4 The Save As Option in the Application Menu.......................................................................................... 14
  1.4.5 The Print Option in the Application Menu.............................................................................................. 17
  1.4.6 The Send E-mail Option in the Application Menu.................................................................................. 18
  1.4.7 The File Information Option in the Application Menu........................................................................... 19
  1.4.8 The Backup And Recover Option in the Application Menu................................................................. 21
  1.4.9 The Help Option in the Application Menu.............................................................................................. 21
  1.4.10 The Options Function in the Application Menu..................................................................................... 22

2 Home tab......................................................................................................................................................... 23

2.1 Clipboard Functions............................................................................................................................................ 23
  2.1.1 The Paste Function.................................................................................................................................. 24
  2.1.2 The Cut Function..................................................................................................................................... 25
  2.1.3 The Copy Function.................................................................................................................................. 26
2.1.4 Format Painter ................................................................. 26

2.2 Font .................................................................................. 26
  2.2.1 Font Format ................................................................. 26
  2.2.2 Border ...................................................................... 28
  2.2.3 Patterns .................................................................... 30

2.3 Alignment ....................................................................... 32
  2.3.1 Aligning Text .......................................................... 32
  2.3.2 Wrapping Text ...................................................... 33
  2.3.3 Merging Cells ...................................................... 34
  2.3.4 Adjusting Indent ................................................... 36

2.4 Number .......................................................................... 36
  2.4.1 Quick Set Format .................................................. 36
  2.4.2 Cell Format .......................................................... 37

2.5 AutoSum ......................................................................... 47

2.6 Filter ............................................................................... 48
  2.6.1 AutoFilter ............................................................. 48
  2.6.2 Reapply ................................................................. 55
  2.6.3 Advanced Filter .................................................. 55
  2.6.4 Show All .............................................................. 58

2.7 Sort ................................................................................. 58

2.8 Format ........................................................................... 60
  2.8.1 Convert Text to Number and Hyperlink .................. 60
  2.8.2 Conditional Formatting ......................................... 60
  2.8.3 Style ....................................................................... 61
  2.8.4 Clear ...................................................................... 64

2.9 Rows and Columns ......................................................... 64
  2.9.1 Selecting Rows and Columns .................................... 64
  2.9.2 Moving Rows and Columns .................................... 64
  2.9.3 Setting Row Height and Column Width ................. 65
  2.9.4 Inserting Cells, Rows, and Columns ...................... 66
2.9.5 Deleting Cells, Rows, and Columns................................................................................................. 68
2.9.6 Fill.................................................................................................................................................... 68
2.9.7 Hiding and Showing Columns and Rows......................................................................................... 74

2.10 Worksheet ......................................................................................................................................... 75
2.10.1 Selecting Sheet.............................................................................................................................. 76
2.10.2 Inserting Sheet............................................................................................................................... 76
2.10.3 Deleting Sheet............................................................................................................................... 77
2.10.4 Protect Sheet................................................................................................................................ 78
2.10.5 Renaming Sheet........................................................................................................................... 79
2.10.6 Moving or Copying Sheet............................................................................................................... 79
2.10.7 Tab Color....................................................................................................................................... 81
2.10.8 Hiding and Showing Sheet........................................................................................................... 83

2.11 Find and Replace................................................................................................................................ 83
2.11.1 Find................................................................................................................................................ 83
2.11.2 Replace......................................................................................................................................... 84
2.11.3 Go To............................................................................................................................................. 84
2.11.4 Select Objects............................................................................................................................... 85

2.12 Format as Table................................................................................................................................ 86

2.13 Symbol.............................................................................................................................................. 87

3 Insert Tab............................................................................................................................................... 88
3.1 Tables.................................................................................................................................................. 88
3.1.1 PivotTable....................................................................................................................................... 88

3.2 Chart................................................................................................................................................... 94
3.2.1 Chart Type....................................................................................................................................... 94
3.2.2 Chart Structure............................................................................................................................... 96
3.2.3 Creating Chart............................................................................................................................... 96
3.2.4 Chart Tools Tab............................................................................................................................. 101

3.3 Picture................................................................................................................................................ 107

3.4 Shapes................................................................................................................................................ 108

3.5 Text Box............................................................................................................................................. 109
3.6 Word Art........................................................................................................................................109
3.7 Header & Footer................................................................................................................................110
3.8 Hyperlink...............................................................................................................................................112
  3.8.1 Create Hyperlink........................................................................................................................112
  3.8.2 Group Create and Cancel Hyperlinks........................................................................................113
3.9 Symbol..................................................................................................................................................114
3.10 Equation................................................................................................................................................116
3.11 Insert Object........................................................................................................................................117
3.12 Insert File Object................................................................................................................................118
3.13 Insert AutoShape................................................................................................................................119
3.14 Screen Grap..........................................................................................................................................121
4 Page Layout Tab......................................................................................................................................121
  4.1 Page Setup........................................................................................................................................121
    4.1.1 Margins.........................................................................................................................................121
    4.1.2 Orientation.................................................................................................................................122
    4.1.3 Size...............................................................................................................................................123
    4.1.4 Print Area.....................................................................................................................................124
    4.1.5 Print Titles...................................................................................................................................125
    4.1.6 Breaks.........................................................................................................................................126
    4.1.7 Page Zoom..................................................................................................................................126
4.2 Arrange................................................................................................................................................128
  4.2.1 Arrange Object Orders................................................................................................................128
  4.2.2 Align...............................................................................................................................................128
  4.2.3 Group............................................................................................................................................130
  4.2.4 Rotate..........................................................................................................................................131
4.3 Themes................................................................................................................................................131
5 Formulas Tab..........................................................................................................................................132
  5.1 Formulas Grammar........................................................................................................................133
    5.1.1 Create Formulas........................................................................................................................134
    5.1.2 Input Formulas........................................................................................................................134
5.1.3 Copy a Formula................................................................. 135

5.2 Function Library......................................................................... 135
  5.2.1 Insert Function..................................................................... 136
  5.2.2 Use Functions in the Table.................................................... 137
  5.2.3 Function Category............................................................... 139

5.3 AutoSum....................................................................................... 165
  5.3.1 Sum of row(s)...................................................................... 165
  5.3.2 Sum of Column(s)............................................................... 167

5.4 Define Names.............................................................................. 168
  5.4.1 Define Name....................................................................... 168
  5.4.2 Create Names..................................................................... 169
  5.4.3 Define Formula Name.......................................................... 169
  5.4.4 Paste Name....................................................................... 169

5.5 Calculation.................................................................................. 170
  5.5.1 Automatic Calculation......................................................... 171
  5.5.2 Manual Recalculation......................................................... 171
  5.5.3 Iteration............................................................................. 172

5.6 Checking...................................................................................... 173

6 Data Tab.......................................................................................... 174

6.1 Import Data................................................................................ 174
  6.1.1 Open data file directly........................................................ 174
  6.1.2 Use ODBC data source connection guide............................ 176
  6.1.3 Edit OLE DB Query............................................................ 178
  6.1.4 External Data Range Properties........................................... 178
  6.1.5 Refresh Data and Refresh All.............................................. 178

6.2 Text to Columns........................................................................ 179

6.3 Duplicates.................................................................................... 182

6.4 Validation................................................................................... 182

6.5 Consolidate................................................................................ 184
  6.5.1 Consolidate by Position...................................................... 184
6.5.2 Consolidate by Category.................................................................................................................. 187

6.6 Group.................................................................................................................................................. 190

6.7 Subtotal................................................................................................................................................ 190

6.8 Show Detail and Hide Detail.................................................................................................................. 191

6.9 Form..................................................................................................................................................... 191

6.10 What-If Analysis................................................................................................................................ 192

6.10.1 Goal Seek....................................................................................................................................... 192

6.10.2 Solver Parameters........................................................................................................................... 193

6.11 Pivot Table......................................................................................................................................... 196

7 Review Tab............................................................................................................................................. 201

7.1 Check Spelling................................................................................................................................... 201

7.2 Comment............................................................................................................................................. 203

7.2.1 Create Comment................................................................................................................................. 204

7.2.2 Edit Comment.................................................................................................................................. 204

7.2.3 Delete Comment............................................................................................................................... 204

7.3 Lock Cell.............................................................................................................................................. 205

7.4 Protect sheet....................................................................................................................................... 205

7.5 Protect Workbook............................................................................................................................... 206

7.6 Share Workbook................................................................................................................................ 206

7.7 Protect and Share Workbook.............................................................................................................. 208

7.8 Allow Users to Edit Ranges.................................................................................................................. 208

7.9 Track Changes..................................................................................................................................... 210

7.10 Thesaurus.......................................................................................................................................... 210

8 View Tab................................................................................................................................................. 211

8.1 View Mode.......................................................................................................................................... 211

8.1.1 Normal............................................................................................................................................ 211

8.1.2 Page Break Preview.......................................................................................................................... 212

8.1.3 Full Screen..................................................................................................................................... 212

8.1.4 Reading Layout............................................................................................................................... 213

8.2 View Check Boxes............................................................................................................................... 214
8.3 Zoom................................................................................................................................. 214
8.4 Freeze............................................................................................................................... 215
8.5 Window Functions........................................................................................................... 216
8.6 Mode................................................................................................................................. 216
9 Developer Tab.................................................................................................................... 217
  9.1 Macros............................................................................................................................. 217
  9.2 Security.......................................................................................................................... 218
  9.3 Other Functions............................................................................................................. 219
10 Special Feature................................................................................................................ 219
1 Kingsoft Spreadsheets Basic Operation

1.1 Brief Introduction

As one of three Kingsoft Office 2016 components, Kingsoft Spreadsheets is an independent and powerful spreadsheet application. Kingsoft Spreadsheets can not only fulfill your daily needs of analyzing data, but also help you to perform more professional data processing tasks.

1.2 Kingsoft Spreadsheets Interface

If you have worked by any Windows programs or Microsoft Excel before, you are already familiar with the Kingsoft Spreadsheets user interface. It has all of the standard window components, such as the title bar, menu bar, status bar and so on.

- **Title Bar**: The title bar displays the name of the workbook. When you create new workbooks, the system will automatically name your workbooks as Book1, Book2 and so on.
- **Menu Bar**: The menu bar contains different commands that you can use to edit the worksheet.
- **Name Box**: The name box displays the selected cell address. If you select more than one cell, it will display the first selected cell address.
- **Formula Bar**: The formula bar will display the content you are editing in the cell.
- **Rows**: The rows are labeled with the numbers 1 to 65536.
- **Document List**: You can easily switch among multiple documents by clicking the Document List icon.
- **Columns**: The columns are labeled with letters in the following pattern: A, B, C, ... Z, AA, AB, AC, ... AZ, BA, BB, BC, ... BZ, CA, ... IA, IB, ... IV, which is the last possible column.
- **Active Cell**: The active cell has a bold border around it and the row and column headers have a deep shading over them. It is this cell that receives your keystrokes and commands.
1.3 Basic Operations

1.3.1 Operations in Cells

Cell is the basic unit for storing data in the spreadsheets. You can select, copy, cut, paste, edit, clear, move, and join cells.

1.3.1.1 Editing in Spreadsheets

There are two types of data in Kingsoft Spreadsheets: text (i.e. Characters or the combination of characters and numbers) and number. All numeric values can be used to carry out calculations. In Kingsoft Spreadsheets, the data in text format will be aligned to the left and the data in number format will be aligned to the right by default.

1.3.1.2 Inputting Text

In Kingsoft Spreadsheets, text refers to characters or the combination of characters and numbers. To input number as text, enter ‘ ’ before you enter the text data.

1.3.1.3 Inputting Numbers

Numbers are composed of the digits 0-9 and some special characters such as: +, -, $, %, etc. There are several tips to consider when inputting numbers:

- When you enter a positive number, you do not have to add a '+' before the number. Even if you add it, it will automatically be omitted.
- When you enclose a number in "()", or parentheses, it means you have input a negative number. For example: (123) refers to -123.
- If you want to enter a fraction, you should add a '0' before it, otherwise the system will display it as date. For example, if you want to input 1/2, you should input 0 1/2. There should be a blank space between 0 and 1/2. Otherwise it will display as 01-Feb.
- When the input number is longer than the cell width or more than 11 digits, it will be automatically displayed in scientific notation.
1.3.1.4 Inputting Date and Time

When inputting date, you can use '/' or '-' to separate the year, month and day. For example, '11/4/19' or '11-4-19'. When inputting time, you can use ':' to separate hours, minutes and seconds. For example, '9:30' and '10:30 AM'.

There are several tips you should pay attention to:

- In Kingsoft Spreadsheets, the date and time are treated as numbers, which means that you can perform calculations with them.
- If you want to enter a 12-hour time, you should add 'AM' or 'PM' after the time. Otherwise it will be treated as a 24-hour time.
- If you want to enter the time and date in to the same cell, you should use a blank space to separate them. For example, '2011-4-19 8:30'.

1.3.1.5 Entering the same data into a discrete area

To enter the same data in to a discrete area, follow the steps below:

1. Hold the <Ctrl> key and select the cells where you wish to enter the same data.
2. Enter data in to the active cell.
3. Press <Ctrl+Enter>.

1.3.2 Multiple summary results in the status bar

In Kingsoft Spreadsheets, multiple summary results will appear in the status bar if you select several numbers at a time. The summary results include: Sum, Average and Count.
The three summary results mentioned above are defaults in Kingsoft Spreadsheets. To adjust any of them, you can right-click the status bar or click the AutoSum icon in the Home tab. The option list will then open and you can add or delete the summary results according to your needs.

### 1.3.3 Smart Contraction

Sometimes we have to enter a lot of information in a cell, which makes it inconvenient to check information in other cells. Kingsoft Spreadsheets provides a smart contraction function to make it much easier to deal with such situation.
1.3.4 AutoComplete Function

The AutoComplete Function makes it easier to enter the same or similar data into different cells. This can improve the speed and efficiency of data entry. To apply this function, the steps are as follows:

1. Find the Application menu and click Options(L) at the bottom right corner.
2. Select the Edit tab in the Options dialogue box and select the Enable AutoComplete for cell values check box, shown as below:
3. When you enter the first character of similar content, the system will automatically provide a drop-down list for you to choose from.
1.3.5 Switching Skins

As you might already know, Kingsoft Office offers four skin / interface styles: **2013 Elegant Black, 2013 Water Blue, 2016 White** and **Classic Style**. Both Office Free 2016 and Office Professional 2016 support to switch skins among the four styles. If you want to choose your favorite interface, you can switch skins by the following steps:

1. In Spreadsheets 2016, click the **Switch UI** icon at the top right corner of the screen.
2. Select a different skin from the current one and press OK. You will need to restart the program to see the change.

![Figure 1.3—4 The Skin Manager drop-down list](image)
Figure 1.3—5 Switch skin style in Office 2013 - Classic Skin

Tips:
Under 2016 style interface, you can press the <Alt> shortcut key to bring up the Classic menu, which is shown under the main toolbar. Press <Alt> again to hide it. This menu style is also available by clicking the arrow beside the program icon. See below:

Figure 1.3-6 Show classic menu in 2013 style interface

1.3.6 Activating Kingsoft Office

To install and activate Kingsoft Office 2016, you just need to Run the installer and follow the instructions in the wizard to start installing Kingsoft Office to your computer.
Then it will automatically jump to the interface of Kingsoft Writer.

Figure 1.3—8 the interface of Kingsoft Writer

1.3.7 Switching Among Multiple Files by the Unique Tab Feature

Much like a modern web browser which allows a user to open multiple web pages as tabs under the same window, Kingsoft Office (Free Office, Professional Office) tab feature offers users the same luxury for word documents, spreadsheets and presentations.

1.3.7.1 Advantages of Kingsoft Office Tab Feature

Common Office suites such as Microsoft Office and OpenOffice force users to open a new window every
time they want to start a new document, which has a tendency to create a cluttered desktop and in some cases even impacts user’s decision whether or not to create a new document. Kingsoft Office’s tab feature eliminates the problem of having too many documents / workbooks / presentations open at one time, allowing user to conveniently switch between documents in one window by pressing the shortcut key <Ctrl+Tab>.

![Figure 1.3-9 Open multiple files in Writer](image)

![Figure 1.3-10 Open multiple files in Spreadsheets](image)

![Figure 1.3-11 Open multiple files in Presentation](image)

The ability to create document tabs not only allows the user to easily see what documents they have opened but also, most importantly, saves the user’s time and ultimately allows the user more time to think about what to write rather than where to find a certain document.

![Figure 1.3-12 Organize tab orders](image)

Users can organize the order of tabs by clicking and dragging a document tab to its desired location, which gives the user control on how to prioritize tabs based on each one’s importance.
1.3.7.2 Closing File Tabs by Double Clicking

Kingsoft Office’s tab feature is built to save user’s time, quickly close the window by double clicking on the desired tab or create a new blank document by right-clicking, pressing the shortcut key <Ctrl+N> or even pressing the tab for a new page as you would on a normal browser.

1.3.7.3 Saving All Tabs in One Click

Right clicking on the tab allows some quick functions including Close Window, Save, Save All, Save As, Close Other Windows, Close All, and Open Folder which is a more practical way of saving work, it avoids a situation where a user is not sure what documents are open and may have to re-check or in rare circumstances save the document under the wrong name.

The interface Kingsoft Office offers is for the best convenience of the user and this feature alone saves time, has improved functionality and usability compared to other less innovative office suites. It eliminates everyday problems that a user may encounter when working with other word processors, spreadsheet software and presentation programs like Microsoft Word, Excel and PowerPoint.

1.3.8 Hiding and Showing the Toolbar

By clicking the Hide the Toolbar icon at the top right corner of the screen, you can hide or show the toolbar.
1.4 The Application Menu

The Application menu is the green icon at the top left corner of the Kingsoft Spreadsheets main interface. The Application menu includes the following functions: New, Open, Save, Save As, Print, Send E-mail, File Information, Backup Management, Help, Options(L) and so on. See below:

![Application Menu](image)

Figure 1.4-1 Application Menu

1.4.1 The New Option in the Application Menu

Click the Application Menu icon to open the drop-down list. Choose the New tab and you can see five options listed in the New Workbook section as shown below:
New Blank Workbook: select this option to create a new blank workbook.

New Excel 2003 Workbook: select this option to create a new 2003 excel workbook.

New from Online Templates: select this option to open the Online Templates interface as shown below:

New from Other Templates: select this option to open the Templates dialogue box as shown below:
You can choose preferred templates from the General, Business, Education, Office, and Personal tabs. Click the OK button to create a new workbook by the chosen template.

- **New From Default Template**: Select this option to create a new workbook by the default template (a blank workbook here).

### 1.4.2 The Open Option in the Application Menu

Click the Application Menu icon to open the drop-down list and choose the Open option. The Open dialogue box will open and show as below:
Choose the intended document in the **Open** dialogue box and click the **Open** button at the right bottom to open the document.

Tips: You can also open the intended document by clicking the **Open** icon at the top left corner of the screen or press <Ctrl+O>.

### 1.4.3 The Save Option in the Application Menu

There are three ways to save the changes you have made to the current workbook:

1. Click the **Application Menu** icon to open the drop-down list and choose the **Save** option.
2. Click the **Save** icon at the top left corner of the screen.
3. Press the shortcut combination <Ctrl+S>.

### 1.4.4 The Save As Option in the Application Menu

Click the **Application Menu** icon to open the drop-down list. Choose the **Save As** tab and you can see seven options listed in the **Save a Copy of the Document** section as shown below:
As you can see, you can save the current document as **WPS Spreadsheets Files**, **WPS Spreadsheets Templates**, **Microsoft Excel 97-2003 Files**, **Microsoft Excel 97-2003 Templates**, **Microsoft Excel 2007/2010 Files**, and **Other Formats**. or you can select **Export to PDF**. The steps are as follows:

1. By choosing any one of them, you can open the **Save As** dialogue box shown as below:
(2) Enter the name you prefer for the current document in the File name text box and choose the file type in the Save as type drop-down list.

(3) Click the Save button to complete the operation.

(4) If you want to cancel the operation, click the Cancel button or click the red cross at the top right corner of the dialogue box.

(5) By clicking the Encryption button at the bottom right, you can open the Security tab in the Options dialogue box. Shown as below:

![Security Tab](image)

Figure 1.4-8 The Security tab

(6) You can set the security related setting here, such as the Document password, Reenter password, Password to modify, etc.

(7) Click the OK button to complete the operation.

You can also export the current file to PDF format. The steps are as follows:

(1) Choose the Export to PDF option in the Save As tab. The Export to Adobe PDF File dialogue box will open and show as below:
17

Figure 1.4-9 The Export to Adobe PDF File dialogue box

(2) In the **Save to** section, choose the location where you want to save the current file.

(3) In the **Export range** section, select the preferred options.

(4) Click the **OK** button to complete the operation.

### 1.4.5 The Print Option in the Application Menu

To print the file, the steps are as follows:

(1) Click the **Application Menu** icon to open the drop-down list and choose the **Print** option. The **Print** dialogue box will open and show as below:
(2) In the **Printer** section, you can choose the preferred printer in the **Name** drop-down list.

(3) In the **Page range** section, you can choose the range of the file which you want to print. You can also enter the specific pages you prefer in the **Pages** text box.

(4) In the **Copies** section, choose the number of copies in the roll-down list. Choose the **Collate** check box and the document will be print one copy after another.

(5) Click the **OK** button to print the document.

### 1.4.6 The Send E-mail Option in the Application Menu

To send the current file to others by E-mail, the steps are as follows:

(1) Click the **Application Menu** icon to open the drop-down list and choose the **Send E-mail** option. The **Send E-mail** task window will open.

(2) You can set the information such as the addressee, the sender, the main topic, and the attachments in the task window.

(3) Click the **Send** button to send the E-mail.
1.4.7 The File Information Option in the Application Menu

Click the Application Menu icon to open the drop-down list. Choose the File Information tab and you can see two options listed in the Document Protection and Properties section as shown below:

![Figure 1.4-11 The File Information tab](image)

Choose the Encryption option and you can open the Security tab in the Options dialogue box as shown in Figure 1.4-8. Then you can set the security related setting here, such as the Document password, Reenter password, Password to modify, etc. Click the OK button to complete the operation.

Set the properties of the document, the steps are as follows:

(1) Choose the Properties option and open the dialogue box shown as below:
(2) In the General tab, you can see the basic information of the document, such as Type, Location, Size, MS-DOS file name, Created time, Accessed time, Modified time, etc.

(3) In the Summary tab, you can enter the information in the corresponding text box, such as Title, Subject, Author, Manager, Company, Category, Keyword, and Comments. Shown as below:
(4) In the **Custom** tab, you can set the **Name**, **Type**, **Value**, and **Property** of the file. Shown as below:

![Screenshot of the Custom tab](image)

Figure 1.4-14 The Custom tab

(5) Click the **OK** button to complete the operation.

### 1.4.8 The Backup And Recover Option in the Application Menu

By choosing the **Backup and Recover** option in the **Application Menu**, you can open the **Backup management** task window at the right side of the screen. Click the **Backup Management** icon again to open the drop-down list, and then you can choose the options listed there, namely **New Workbook**, **PivotTable**, **Selection Pane**, **Formatting**, and **Backup Management**. By choosing any one of them, the corresponding task window will open and you can set preferred values there.

### 1.4.9 The Help Option in the Application Menu

Click the **Application Menu** icon to open the drop-down list. Choose the **Help** tab and you can see the options listed in the **Feedback and Product Information** section as shown below:
You can choose any of the options, namely WPS Spreadsheets Help, WPS Office Homepage, User Feedback, Feedback by Email, WPS Office Facebook, Check for Updates, Enter Activation Code, and About WPS Spreadsheets, to open the corresponding web pages and know more about Kingsoft Spreadsheets.

Tips: You can also click the Help icon at the top right corner of the screen or press the <F1> shortcut key to open the relevant web pages.

1.4.10 The Options Function in the Application Menu

Click the Application Menu icon to open the drop-down list. Click the Options icon at the bottom right of the drop-down list. The Options dialogue box will open and show as below:
You can see a number of tabs at the left side of the dialogue box. By choosing any one of them, the corresponding tab will open at the right side where you can select or deselect the check box to set the preferred values.

Click the red **Exit** icon at the bottom right or click anywhere in the document to close the **Application Menu**.

# 2 Home tab

## 2.1 Clipboard Functions

After selecting the text or object, you can move, copy, delete and carry out various other commands on the selected content. You can complete all of these operations through the control command, the shortcut keys or the mouse. The clipboard functions offered by Kingsoft Spreadsheets are shown as below:
2.1.1 The Paste Function

Paste refers to moving the contents from the system clipboard to the file at the designated insertion point. The paste operation can only be performed unless the clipboard is not empty. To paste contents, follow the steps below:

(1) Select the contents you want to paste and click the arrow on the Paste icon in the Home tab. The Paste drop-down list will then open and show as below:

![Paste drop-down list](image)

Figure 2.1—2 The Paste drop-down list

(2) Kingsoft Spreadsheets provides seven different methods of pasting contents.

- **Formulas**: Paste the formulas contained in a data set rather than the data itself.
- **No Borders**: Only paste the cell contents without the cell borders.
- **Values**: Copy the selected cells containing formats and formulas and select the Values option in the Paste drop-down list. By doing this, you can paste the values in the cells without changing the formats and formulas.
- **Transpose**: To rearrange row data to be displayed in columns, you should choose the Transpose option in the Paste drop-down list. Copy the selected row data and choose the Transpose option in the desired position to complete the action.
- **Paste as Picture**: Select the contents which you want to paste as a picture, put the cursor to the place where you want to paste and choose the Paste as Picture option in the drop-down list. By doing this, you can paste the intended contents as picture.
- **Paste as Unformatted Text**: Choose this option and the selected contents will be removed all formats and pasted as plain text.
**Paste Special** option includes the options mentioned above. However, you can also choose **Paste Special** in the **Paste** drop-down list directly, which offers more options for you. Just right-click and choose the **Paste Special** option in the context menu and the **Paste Special** dialogue box will open and show as below:

![Paste Special Dialogue Box](image)

**Figure 2.1—3 The Paste Special dialogue box**

You can then select the preferred check box in the above dialogue box to set the values for pasting contents.

3. You can also paste by pressing <Ctrl+V>. This method will paste all copied content to the designated area.

4. Right-click on the document to open the context menu, you can then select the **Paste** option there to paste the content.

### 2.1.2 The Cut Function

Cut refers to removing the currently selected contents within the file, and moving them to the system clipboard where you can paste these contents to other places. You can use the cut function by any of the three methods listed below:

1. Open the **Home** tab and click the **Cut** icon .
2.1.3 The Copy Function

Copy refers to duplicating the currently selected contents to the system clipboard, so that you can paste these contents to other places. However, the selected contents are still retained in the file. You can use the copy function by any of the three methods listed below:

(1) Click the Copy icon in the Home tab.
(2) Press the <Ctrl+C>.
(3) Right-click the selected contents and select the Copy option in the context menu.

2.1.4 Format Painter

Format Painter is a commonly used tool to replicate formats. It can replicate the format of selected objects, text, and cells, and apply it to the corresponding content you prefer.

(1) Put the cursor on the cells or objects whose format will be replicated.
(2) Click the Format Painter icon in the Home tab.
(3) The mouse pointer will then change into a brush.
(4) Select the object or cells which would be formatted to complete the operation.

Tips: If you want to use format painter continuously, you can double-click the Format Painter icon to highlight it as a brush.

2.2 Font

The content of different cells can be set in different font formats, borders, fill colors, etc. according to your needs. All of these things make it easier to highlight and emphasize the content you prefer.

2.2.1 Font Format

The font format setting refers to set the font, size, style, color of the contents.
2.2.1.1 Font

Kingsoft Spreadsheets provides a variety of fonts for your choice. There are appropriate fonts for different tastes, situations and requirements. To set the font, follow the steps below:

(1) Select the cell or text for which you want to set the font.

(2) Click the Font drop-down list in the Home tab and select an appropriate font.

The list is shown in the following figure:

![Font drop-down list](image)

Figure 2.2—1 The Font drop-down list
2.2.1.2 Font Size

Different font sizes can be used within a single document. To set the font size, follow the steps below:

(1) Select the cell or text for which you want to set the font size.
(2) Click the Size drop-down list in the Home tab and select the appropriate font size. You can also input numbers between 1 and 409 in the drop-down list box and press Enter.

It is also possible to quickly Increase and Decrease the font size. These icons can be found in the Home tab.

2.2.1.3 Font Style

Font style represents the format of the characters within the text. There are several commonly used control buttons. These buttons are used to set the font style of the selected text. The functions of these buttons are as follows:

- **Bold**: Set the selected text in bold or cancels the setting if the text is already in bold.
- **Italic**: Set the selected text in italic or cancels the setting if the text is already in italic.
- **Underline**: Set an underline for the selected text or cancels the setting if the text is already underlined.
- **Text color**: Set an appropriate color for the selected text. Click the arrow in the icon and open the drop-down list to make the selection. The automatic color is black.
- **Clear**: Clear everything in the selected cell, or selectively remove the formats, contents, or comments in the selected cell. You can also apply this function by clicking the Format icon in the Home tab and select the preferred option in the Clear drop-down list.
- **Fill Color**: Click to select a background color for the selected cell in the drop-down list.

2.2.2 Border

The color of the grid lines in the worksheet is gray by default. Grid lines are not displayed when you print the file, but if you need to print the grid lines, you should set the borders for them. To set the borders, follow the steps below:

(1) Select the cells for which you want to set the borders.
(2) Click the **Other Borders** icon in the **Home** tab and select different borders from the drop-down list. The list is shown in the following figure:

![Border drop-down list](image)

Figure 2.2—2 Border drop-down list

- **Draw Border**: Click the **Draw Border** icon and select the **Draw Border** option in the drop-down list. The mouse will then change into a pen shape which allows you to draw an outside border for the selected cell area.

- **Draw Border Grid**: Click the **Draw Border** icon and select the **Draw Border Grid** option in the drop-down list. The mouse will then change into a pen shape which allows you to draw border grid lines for the selected cell area.

- **Erase Border**: Click the **Draw Border** icon and select the **Erase Border** option. The mouse will then change into an eraser and you can erase the border of the selected cell area.

- **Line Color**: Select a preferred color for the border line in the drop-down menu. The automatic color is black.

- **Line Style**: Select a preferred style for the border line in the drop-down menu. The automatic style is straight line.

An alternative method to set cell borders is by the **Format Cells** dialogue box:

(1) Select the preferred cell area.
(2) Click the **Other Borders** icon in the **Home** tab and select the **More Borders** option at the bottom of the drop-down list. Choose the **Border** tab in the **Format Cells** dialogue box.

(3) You can set the print display of the outside border and inside border in the **Presets** section.

(4) Select the style of border lines in the **Style** drop-down list.

(5) Select the color of border lines in the **Color** drop-down list.

(6) Complete the operation by pressing the **OK** button at the bottom.

![Format Cells dialogue box](image)

**Figure 2.2—3** Set the border in the Format Cells dialogue box

### 2.2.3 Patterns

You can complete the cell shading setting by the following steps:

(1) Select the cell or cell range that you want to apply shading to. In the **Home** tab, click the **Other Borders** icon and select the **More Borders** option in the drop-down list. The **Format Cells** dialogue box
will open and show as below:

Figure 2.2—4 The Patterns tab

(2) Choose the Patterns tab in the Format Cells dialogue box and several options will be available. Background Color section offers shading colors for the cell. Pattern Style section offers shading patterns for the cell and Pattern Color section offers shading pattern colors for the cell. Choose the appropriate option in the corresponding sections.

(3) Press the OK button to complete the operation.

You can select the cell or the cell range and right-click it to open the Context menu. Select the Format Cells option and the dialogue box will pop up.
2.3 Alignment

2.3.1 Aligning Text

Select a cell or a cell range and go to the Home tab. Kingsoft Spreadsheets provides seven alignment icons: Top Align, Middle Align, Bottom Align, Align Text Left, Center, Justify and Align Text Right. Select the proper style you want by clicking the corresponding icon. You can also set the alignment of cells by the Format Cells dialogue box.

The steps are shown as follows:

(1) Select the cells you want to align.

(2) Click the Other Borders icon in the Home tab.

(3) Choose the More Borders option in the drop-down list to open the Format Cells dialogue box.

Select the Alignment tab and choose an appropriate Horizontal and Vertical alignment option in the Text alignment section.
(4) Press the OK button to complete the operation.

### 2.3.2 Wrapping Text

If you need to input multiple lines of data into a cell, take the following steps:

1. Select the cell with the data you want to wrap.

2. Click the **Wrap Text** icon in the **Home** tab to wrap the data.

Aside from the way mentioned above, you can also wrap the data through the **Format Cells** dialogue box. The steps are shown as follows:

1. Select the cell with the data you want to wrap.

2. Click the **Other Borders** icon in the **Home** tab and choose the **More Borders** option in the drop-down list.

3. The **Format Cells** dialogue box will open. In the **Alignment** tab, select the **Wrap text** check box in...
the **Text control** section. Shown as below:

![Figure 2.3-2 The Wrap text check box](image)

(4) Click the **OK** button to complete the operation.

The keyboard shortcut combination `<Alt+Enter>` also performs this function.

### 2.3.3 Merging Cells

There are four options in the **Merge and Center** drop-down list: **Merge and Center**, **Merge Across**, **Merge Cells**, **Center Across** and **Unmerge Cells**.

In the **Home** tab, select options in the **Merge and Center** drop-down list as shown below. These options can make the merging of cells much quicker and easier.
• **Merge and Center**: The selected cells will be merged and the content they contain will be aligned to the center.

• **Merge Across**: Selected columns and rows will be merged, but the number of columns and rows will not change in this case.

• **Merge Cells**: Merge the selected cells.

• **Center Across**: The content in every cell will be aligned to the center, but the cells will not be merged.

  The alignment standard is based on the longest cell selected.

• **Unmerge Cells**: This means splitting the cell.

You can merge or split cells by the following steps:

1. Select the cell or cells.

2. Click the **Merge and Center** icon in the **Home** tab.

You can also merge or split cells by the **Format Cells** dialogue box. Follow the steps below:

1. Select the cells that need to be merged or split.

2. Right click and choose the **Format Cells** option in the context menu.

3. Choose the **Alignment** tab in the **Format Cells** dialogue box and select or deselect the **Merge cells** check box in the **Text control** section.
(5) Press the OK button to complete the operation.

### 2.3.4 Adjusting Indent

To change the indent of the cell content (the margin between the border and the text), you can use the Decrease Indent icon and the Increase Indent icon in the Home tab.

- **Decrease Indent**: Reduce the distance between the cell border and the content.
- **Increase Indent**: Increase the distance between the cell border and the content.

### 2.4 Number

#### 2.4.1 Quick Set Format

You can easily set the format of the selected cells by several icons in the Home tab such as: **Currency**, **Percent**, **Accounting**, etc.
Percent Style, Comma Style, Increase Decimal, and Decrease Decimal.

- **Currency**: Add a currency format for the selected cell(s). For instance, choose Euros instead of Dollars.
- **Percent Style**: Display the values in the selected cell(s) as percentages.
- **Comma Style**: Display the value of the cell with a thousands separator.
- **Increase Decimal**: Display the data in higher accuracy by increasing the decimal digits.
- **Decrease Decimal**: Display the data in lower accuracy by decreasing the decimal digits.
- **Scientific Style**: Format as a number in scientific notation, with 2 decimal places.

### 2.4.2 Cell Format

There are 12 categories in the cell format properties. These categories are: **General, Number, Currency, Accounting, Date, Time, Percentage, Fraction, Scientific, Text, Special**, and **Custom**.

There are several ways to open the Format Cells dialogue box in order to set the format properties for the cell.

- Click the **Settings** icon in the **Home** tab and choose the **Cells** option in the drop-down list. The **Format Cells** dialogue box will open and the **Number** tab will be available.
- Right click the mouse and choose the **Format Cells** option in the context menu. The **Format Cells** dialogue box will pop up and the **Number** tab will be available.
- Click the **Format** icon in the **Home** tab and choose the **Cells** option in at the bottom of the drop-down list. The **Format Cells** dialogue box will open and the **Number** tab will be available.
- Press `<Ctrl+1>` to open the **Format Cells** dialogue box and select the **Number** tab.

You can choose a format type in the **Category** section of the **Number** tab. When you choose different format types, there will be different information references displayed at the right side of the dialogue box. You can adjust the values according to the references so as to achieve a custom effect.

- **General**

  The **General** format is the default number format when you type a number into a cell. It does not include any special format for numerical values.
Spreadsheets 2016 User Manual

- **Number**

Select the **Number** option in the **Category** section and a **Sample** box will appear at the right side of the dialogue box, which previews the changes of decimal, 1000 separator, and negative value made to the number format. Shown as below:

![Figure 2.4-1 Number format and options](image)

After selecting the **Number** option, you can adjust the following settings in the dialogue box:

- Decimals and 1000 separator can be added to the number format.
- You can set the negative number format in the **Negative numbers** list box.

- **Currency**

Select the **Currency** option in the **Category** section and a **Sample** box will appear at the right side of the dialogue box, which previews the changes in decimal, currency symbol and negative value usage. Shown as below:
After choosing the **Currency** option, you can set the basic display style for currency in the dialogue box. These display settings allow you to customize the **Decimal places**, **Symbol** and the display format of the **Negative numbers**.

- **Accounting**

Choose the **Accounting** option in the **Category** section. The **Sample** box on the right displays the format changes. You can define the basic accounting display format by customizing the **Decimal places**, **Symbol**, etc. Figure 2.4-3 displays the **Accounting** format and options.
**Date**

Select the **Date** option in the **Category** section. You can choose the preferred date style in the **Type** list box and preview the change there. See below:
Time

Select the **Time** option in the **Category** section. You can choose the preferred time style in the **Type** list box and preview the change there. See below:
Figure 2.4-5 Time format and options

- **Percentage**

Select **Percentage** in the **Category** section. You can set the decimal digits in the roll-down list and preview the changes in the **Sample** box. See below:
Figure 2.4-6 Percentage format and options

- **Fraction**

Select **Fraction** in the **Category** section. You can choose the preferred fraction type in the Type list box and preview the change in the **Sample** box. See below:
Figure 2.4-7 Fraction format and options

- **Scientific**

Select **Scientific** in the **Category** section. The **Sample** box on the right displays the format changes. You can set the decimal digits in the roll-down list. See below:
Figure 2.4-8 Scientific format and options

- **Text**

Select **Text** in the **Category** section. Contents in the text format cells are treated as text even if they are numbers. The cell is displayed exactly as entered.

- **Special**

Select **Special** in the **Category** section. There are three types of special formats, namely the **Zip code**, **Zip Code + 4** and **Social Security Number**. See below:
Custom

Select **Custom** in the **Category** section. You can set various kinds of customized data formats in the **Type** list box. See below:
Click the OK button to complete the operation.

## 2.5 AutoSum

Kingsoft Spreadsheets provides the AutoSum function which could be applied to perform several simple operations, namely **Sum**, **Average**, **Count**, **Max**, and **Min**. See below:
Select the intended cells and you can perform the corresponding operation by choosing the preferred option. The result will be displayed directly after the selected cells.

- **Sum**: Sum up the numbers in the selected cells.
- **Average**: Work out an average of the numbers in the selected cells.
- **Count**: Count the number of the selected cells.
- **Max**: Choose the maximum among the numbers in the selected cells.
- **Min**: Choose the minimum among the numbers in the selected cells.

Choose the **More Functions** option in the bottom of the **AutoSum** drop-down list and the **Insert Function** dialogue box will then open where you can apply preferred function to the selected cells.

### 2.6 Filter

Filtering data is a quick and easy way to find and work with a subset of data in a range of cells or in a table. Filtered data displays only the rows that meet the criteria you have specified and hides rows that you don’t want to display.

#### 2.6.1 AutoFilter

AutoFilter makes it easier to find and process subsets of data in the spreadsheets. You can create criteria to filter data. Only those rows which meet the criteria you have specified will be displayed. Filtering doesn’t rearrange rows. It just hides the rows you don’t want to display.

Automatic filter includes: Filter by value, filter by color, text filter, number filter, and custom filter. Here we’ll introduce these features.
2.6.1.1 Filter by Value

To filter by value, follow the steps below:

1. Select the column(s) you want to filter. Click the AutoFilter icon in the Home tab and choose the AutoFilter option in the drop-down list.

2. A drop-down button will appear at the first row of the columns you have selected.

3. Click the drop-down button and you can set the filter in the drop-down menu. For example, select item 3 in the Student No. drop-down list. See below:

![Filter by Value](image)

Then the selected columns will be filtered by the value you have specified. And all the rows that meet the criteria will be displayed. See below:
2.6.1.2 Filter by Color

In Kingsoft Spreadsheets, if you have applied different colors to the data or different cell colors, you can filter the data by these colors.

Follow the steps below to filter data by the cell color or the font color:

1. Select the range of cells you want to filter.
2. Click the AutoFilter icon in the Home tab.
3. Click the drop-down arrow in each cell of the first line in the selected range. Choose the Filter by Color tab in the drop-down menu. See below:

4. You can either filter the data by cell color or font color. Choose one color from the above cell color and font color list. For example, select the font color of Red. You will see the filter result like below:
If you want to remove the color filter you have applied to the worksheet data, follow the steps below:

1. Click the drop-down button in the column header.

2. Click the **Clear** icon at the upper side of the menu. See below:

![Figure 2.6-5 Clear the Filter by Color](image)

Thus the filter by color will be removed.

### 2.6.1.3 Text Filter

When the contents in the column is in text form, click the drop-down button and choose the **Text Filter** tab at the top right corner of the drop-down menu. A series of options are offered as shown below:
You can specify the filter condition as **Equals**, **Not Equal To**, **Begin With**, **End With**, **Contains**, and **Does Not Contain**. By choosing any one of them, the **Custom AutoFilter** dialogue box will open where you can set the values to meet your requirements.

### 2.6.1.4 Number Filter

When the contents in the column is in number form, click the drop-down button and choose the **Number Filter** tab at the top right corner of the drop-down menu. A series of options are offered as shown below:
You can specify the filter condition as **Equals, Not Equal To, Greater Than, Greater Than Or Equal To, Less Than, Less Than Or Equal To, and Between**. By choosing any one of them, the **Custom AutoFilter** dialogue box will open where you can set the values to meet your requirements.

The most frequently used options are **Top 10, Above Average, and Below Average**. You can select them either in the **Number Filter** tab or at the bottom of the drop-down menu.

Select the **Above Average** or the **Below Average** option, the corresponding filter function will be applied to the selected cells.

To apply the **Top 10 AutoFilter**, follow the steps below:

1. Choose the **Top 10** option in the **Number Filter** tab and the **Top 10 AutoFilter** dialogue box will open and show as below:

![Top 10 AutoFilter dialogue box](image)

2. Enter the values in the **Show** section and click the **OK** button to complete the operation.
2.6.1.5 Custom Filter

If you want to create a criteria to filter by a data range or filter by some comparison operators more complex than 'Equal to', you can customize the filter function. The operation steps are shown as follows:

1. Select the data columns.
2. Click the AutoFilter icon in the Home tab and choose the AutoFilter option in the drop-down list.
3. Click the roll-down button and choose the Custom Filter option at the bottom of the Text Filter or Number Filter tab. See below:

![Custom Filter option](image)

Figure 2.6-9 Custom Filter option

4. In the Custom AutoFilter dialogue box, set the operation conditions and upper and lower limit values. See below:

![Custom AutoFilter dialogue box](image)

Figure 2.6-10 Custom AutoFilter dialogue box

5. Click the OK button to complete the operation. The filter result is shown as below:
### 2.6.2 Reapply

After making changes to the data, you can use the **Reapply** function in the **AutoFilter** drop-down list to re-filter the data by the same condition you have specified. For example, you have filtered the **Score 1** column by the condition **Above Average**. Then you change the score in B7. See below:

![Figure 2.6-12 Modify the data](image)

At this point, select the **Reapply** option in the **AutoFilter** drop-down list. The score in B7 after the change is no longer qualified for the condition you have specified, i.e. **Above Average**. Thus it is filtered out. See below:

![Figure 2.6-13 Filter result](image)

### 2.6.3 Advanced Filter

The **Advanced Filter** option allows you to use complex conditions to filter a range. The filter result can be displayed either in the original worksheet or in a new location. Those rows which don’t meet the criteria will be hidden.

To specify the conditions of the **Advanced Filter** function, you have to create the specific **Criteria range**
first. Mind that the criteria range should be created out of the data range which you want to filter.

- **Multiple conditions in a single column**: if you want to filter the data by conditions of the same category, you can simply enter the conditions under the header of the category. For example, to filter the data by the condition “Name is Jane or Flora”. The criteria range and filter result are shown as below:

  ![Figure 2.6-14 Multiple conditions in a single column](image)

- **Multiple conditions in a single row**: if you want to filter the data by more than two conditions, you can enter them from the right to the left under the corresponding categories. For example, to filter the data by the conditions “Age > 20” and “Occupation is teacher”. See below:

  ![Figure 2.6-15 Multiple conditions in a single row](image)

- **Multiple conditions in multiple rows and columns**: if you want to filter the data by one or another condition, you can enter the name of the conditions in different columns and enter the condition in different rows under the corresponding name. For example, to filter the data by the condition “Age < 36” or “Occupation is policeman”. See below:

  ![Figure 2.6-16 Alternative conditions](image)

If you want to filter the data by the same condition in one category and by alternative conditions in another category, enter the same condition under the former category while enter the alternative
conditions in different rows under the later category. For example, to filter the data by the same condition “20<Age<55” and by the alternative conditions “Occupation is teacher” or “Occupation is policeman”. See below:

![Figure 2.6-17 The same condition and alternative conditions](image)

Tips: if you want to filter the data multiple conditions, you should enter them in the same row. If you want to filter data by alternative conditions, you should enter them in different rows of the same column.

To apply the Advanced Filter function, follow the steps below:

1. Select the Advanced Filter in the AutoFilter drop-down list. The Advanced Filter dialogue box will open and show as below:

   ![Figure 2.6-18 The Advanced Filter dialogue box](image)

   - **Filter the list, in-place**: hide data rows that don’t fit the filter condition and display the filter result in the original worksheet.
   - **Copy to another location**: copy the data rows that fit the filter condition to another location. But the data rows which don’t fit the filter condition will remain in the original worksheet and won’t be hidden. It is very convenient to compare the data in this way.

2. Select the **Copy to another location** and the **Unique records only** check box. The filter result will be copied to the specified place you have chosen.
(3) Select the **List range**, **Criteria range** (which you have created as shown above), and **Copy to** range in the worksheet. See below:

![Selecting ranges](image)

Figure 2.6-19 Select the ranges

(4) Click the **OK** button to complete the operation.

### 2.6.4 Show All

If you want to restore the filtered data, you can either select the **Show All** option in the **AutoFilter** drop-down list or press `<C>` in the keyboard. Then all the data will be restored and displayed in the worksheet.

### 2.7 Sort

At times, it is better to have the worksheets in your workbook arranged in a specific order, which will make it easier to navigate through your document. The sort function in Kingsoft Spreadsheets allows you to arrange the data in descending and ascending order. The operation steps are as follows:

1. Select any cell or cells in the worksheet which you want to sort.
2. Click the **Sort** icon in the **Home** tab and you can see that there are three options in the drop-down list, namely **Ascending**, **Descending**, and **Custom Sort**. See below:
(3) You can choose the **Ascending** option to sort the data in the ascending order or choose the **Descending** option to sort the data in the descending order. When you select the **Custom Sort** option, the **Sort** dialogue box will open and show as below:

![Sort dialogue box](image)

Figure 2.7-2 The Sort dialogue box

(4) Choose the sort range in the drop-down list and select the corresponding check box on the right according to your needs.

(5) Press the **OK** button to complete the operation. The data in the worksheet will be sorted by the values you have specified. The result is shown below:
2.8 Format

2.8.1 Convert Text to Number and Hyperlink

Kingsoft Spreadsheets provides the function to convert text to number and hyperlink. You can apply the Convert Text to Number function or the Convert Text to Hyperlink function.

- When you want to convert a large amount of data in text format to numeric format, do the following: Click the Format icon in the Home tab and select the Convert Text to Number option in the Format drop-down list.

- When a large number of hyperlinks are not active, you can activate them altogether. Select the contents you want to change to hyperlinks. Click the Format icon in the Home tab and select the Convert Text to Hyperlink option in the Format drop-down list.

2.8.2 Conditional Formatting

You can set conditions for the cells. When the cells meet these conditions, the program will automatically apply some type of formatting to them.

You can set three conditions at a time and use formulas or cell values as the condition. For example, change the color of the cell to yellow when the date in the cell matches the current date. This function can be used to remember the birthday of friends or employees. To set this kind of condition, follow the steps below:
(1) Select the intended cell or cells.

(2) Click the Format icon in the Home tab and choose the Conditional Formatting option in the drop-down list. The Conditional Formatting dialogue box will open and show as in Figure 2.5-1.

(3) Select the Cell value is option and the equal to option in the Condition 1 drop-down list. Input ‘=today()’ in the edit box.

(4) Click the Format button and the Format Cells dialogue box will open where you can set the fill color of the selected cell into yellow. You can also set other formats for the cell, such as Number, Font, Border, and Patterns. Click the OK button at the bottom right to return to the Conditional Formatting dialogue box.

(5) Click the OK button to complete the operation. The effect is shown below:

![Conditional Formatting dialogue box](image)

Figure 2.8-1 Conditional Formatting dialogue box

(6) You can add other conditions to the selected cell by clicking the Add button at the bottom and repeating the operation above.

### 2.8.3 Style

In Kingssoft Spreadsheets, you can use the built-in styles directly. To use these styles, follow the steps below:

(1) Select the cells that you want to apply a style.

(2) Click the Format icon in the Home tab and choose the Cell Styles option in the drop-down list. See below:
(3) There are five sections in the drop-down list of **Cell Style**: Good, Bad and Neutral, Data and Model, Title, Themed Cell Styles and Number Format. Meanwhile, there are a lot of styles in each section.

- **Good, Bad and Neutral**: Convert the selected cell to the color effect you want. Green is used to show “Good”; Pink is used to show “Bad”; Orange is used to show “Neutral”; White is used to show “Normal”.

- **Data and Model**: There are many styles to choose, such as: Hyperlink, Followed, Note, Input, Output and so on. You can choose the style you need to show your data and model.
Title: There are many styles to choose, such as: Title, Heading1, Heading2, Heading3, Heading4 and Total. You can choose the style you need to show your title.

Themed Cell Styles: There are six styles and with the weakening of the color in each accent to emphasize the importance of this cell.

Number Format: There are five styles in the section: Comma, Comma[0], Currency, Currency[0], Percent. Choose one from the list and you will see its styles in the Style includes part.

(4) Choose the New Cell Style option in the drop down list of Cell Style and the Style dialogue box will open. See below:

![Figure 2.8-3 Add a new style]

Then enter a name for the new style in the Style name section and press Add button.

(5) Choose the Merge Style option in the bottom of the Cell Style drop-down list and the Merge Styles dialogue box will open. See below:

![Merge Styles]

2.8.4 Clear

Select the Clear option in the Format drop-down list or click the Clear icon in the Home tab and you can see that Kingsoft Spreadsheets provides four types of clear options.

- **All**: Select the cells that you want to clear. Choose the All option in the Clear drop-down list. You can then clear all the contents in the selected cells.

- **Formats**: Select the cells whose formatting you want to clear. Choose the Formats option in the Clear drop-down list, which will clear the format but keep the content intact.

- **Contents**: Select the cells whose contents you want to clear. Choose the Contents option in the Clear drop-down list, which will clear the contents but keep the format intact.

- **Comments**: Select the cells whose comments you want to clear. Choose the Comments option in the Clear drop-down list. When the little red triangle disappears, this means cell comments have already been cleared.

Thus, you can select the clear options according to your requirements.

2.9 Rows and Columns

You can change the structure of the worksheet by performing operations on it. The main operations include: select, move, set row height and column width, insert, delete, fill, and hide and display rows and columns.

2.9.1 Selecting Rows and Columns

If you want to carry out operations on rows or columns, you have to select them first. Click the row number or the column label to select a single row or a single column. You can select a single row or column first, press the <Shift> key, and click another row number or column label at the same time. In this way, you can select two or more than two rows (or columns) which are adjacent. An alternative is to press the <Ctrl> key and click different row numbers or column labels at the same time. In this way, you can select more than one row (or column) which are non-adjacent.

2.9.2 Moving Rows and Columns

If you want to adjust the display order of the rows and columns, you can move them to the proper position.
To do so, follow the steps below:

1. Select the rows or columns you want to move.

2. Move the mouse to the border of the selected rows or columns. When the shape of the mouse changes from an arrow to a cross, you can drag the mouse to the specified position.

3. Release the mouse and the rows and columns will be moved to the specified position.

### 2.9.3 Setting Row Height and Column Width

You can adjust the height of the rows and width of the columns if you feel they are not suitable at the default size. To set the row height and column width, follow the steps below:

1. Select the rows and columns.

2. Click the **Rows and Columns** icon in the **Home** tab. The **Rows and Columns** drop-down list is shown below:

   ![Rows and Columns drop-down list](image)

   *Figure 2.9-1 Rows and Columns drop-down list*

3. Select the **Row Height** or **Column Width** option in the drop-down list and the corresponding dialogue box will open where you can set the row height and the column width. See below:
(4) Select the **AutoFit Row Height** or **AutoFit Column Width** option in the drop-down list and the row height and column width will automatically fit the contents of the rows and columns.

(5) Select the **Standard Width** option and the corresponding dialogue box will open where you can set the standard width for the columns. See below:

![Standard Width dialogue box](image)

(6) Click the **OK** button to complete the operation.

Tips: You can also accomplish the aforesaid operations by the context menu. Select the rows or columns, right-click the mouse, and choose the **Row Height** or **Column Width** option in the context menu.

### 2.9.4 Inserting Cells, Rows, and Columns

Select the **Insert Cells** option in the **Rows and Columns** drop-down list, you can see that there are three options, namely **Insert Cell**, **Insert Rows**, and **Insert Columns**.

To insert cells, follow the steps below:

1. Select the position where you want to insert cells.

2. Choose the **Insert Cell** option in the **Insert Cells** drop-down list. The **Insert** dialogue box will open and show as below:
(3) Then you can adjust the position of the inserted cells by setting the values in the dialogue box.

(4) Click the OK button to complete the operation.

To insert rows, follow the steps below:

(1) Select the position where you want to insert rows.

(2) Choose the Insert Rows option in the Insert Cells drop-down list. You can then insert a row in the worksheet. The process is shown below:
2.9.5 Deleting Cells, Rows, and Columns

You can delete any unwanted cells, rows, and columns by the following two ways:

- Select the unwanted cells, rows, and columns. Click the **Rows and Columns** icon in the **Home** tab and choose the **Delete Cells** option. There are three options in the drop-down list. You can delete the selected cells, rows, and columns by choosing the corresponding option. See below:

- Select the unwanted cells, rows, and columns, right-click the mouse, and choose the **Delete** option in the context menu.

2.9.6 Fill

To avoid entering large amounts of repetitive data manually, you can use the **Fill** function to fill cells in a more efficient manner.
2.9.6.1 Allow Cell Drag and Drop

Kingsoft Spreadsheets allow users to apply the fill function by default. You can also manually turn on or turn off the Allow cell drag and drop function. The steps are as follows:

(1) Click the Application Menu icon at the top left corner of the screen to open the drop-down list. Click the Options icon at the bottom right and open the Options dialogue box. Choose the Edit tab in the dialogue box as shown below:

![Figure 2.9-7 The Edit tab](image)

(2) Select or deselect the Allow cell drag and drop check box to turn on or turn off this function.

2.9.6.2 Fill Data by the Fill Handle

There are two types of data series commonly used to fill cells in Kingsoft Spreadsheets. The first type includes: years, months, weeks, quarters, and other text-type sequences. For text-type sequences, all you need is to enter values in the first cell, and then drag the fill handle to
accomplish the filling. The operation steps are as follows:

(1) Select the cell range.

(2) Move the mouse to the lower right corner of the data field and the pointer will change into a cross.

(3) Drag the cross down to the last cell in the cell range and release the mouse. The result is shown as follows:

![Figure 2.9-8 Auto Fill](image)

The second type includes: 1,2,3, 2,4,6, and other numeric sequences. For numeric sequences, you need to enter the first two numbers which display the change pattern, and then drag the fill handle to fill in the specified pattern.

For non-sequence text (such as “Office”) and numeric sequences that don’t specify the change pattern (such as 200), drag the fill handle to duplicate the content.

### 2.9.6.3 Fill Data by the Fill Drop-down List

You can also apply the fill function by the Fill drop-down list. Follow the steps below:

(1) Select the position adjacent to the cells, rows, and columns whose content you want to duplicate.

(2) Choose the Fill option in the Rows and Columns drop-down list. There are several options offered in the Fill drop-down list. See below:
(3) You can choose the option according to your needs. The function of the options are as follows:

- **Down**: insert the contents in the above cells or rows to the lower position.
- **Right**: insert the contents in the left cells or columns to the right.
- **Up**: insert the contents in the lower cells or rows to the upper position.
- **Left**: insert the contents in the right cells or columns to the left.

**Tips**: The difference between filling with duplicated data and filling with sequence data lays in that if you want to fill the cells with duplicated data, you have to press `<Ctrl>` and drag the fill handle at the same time; if you only drag the fill handle, the system will automatically fill the cells with sequence data.

### 2.9.6.4 Across Sheets

The operation steps are as follows:

(1) Select the data that you want to fill into other worksheets within the same workbook.
(2) Press <Shift> and select the worksheet you want to fill with the data.

(3) Select the **Across Sheets** option in the **Fill** drop-down list. There are three options in the **Fill Across Worksheets** dialogue box as shown below:

- **All**: The same contents and formats will be filled without change.
- **Contents**: Only fill with the same contents while the existing formats remain.
- **Formats**: Only fill with the same formats while the existing data remains.

(4) Select the **All** option and press the **OK** button to complete the operation. The result is shown as below:
2.9.6.5 Series

To set the fill series, follow the steps below:

(1) Select the rows and columns to which you have applied the fill series function.

(2) Select the Fill option in the Rows and Columns drop-down list.

(3) Choose the Series option and the Series dialogue box will open and show as below:

![Series dialogue box]

(4) The Rows or Columns option will automatically be selected specifying the target object in the Series in section.

(5) Select a series type in the Type section.
   - Linear: the contents will be inserted in the linear type.
   - Growth: the contents will be duplicated.
   - Date: the contents will be inserted in the date format.
   - AutoFill: the contents will be inserted by default.

(6) Enter the step value and stop value in the corresponding enter box.

(7) Click the OK button to complete the operation.

2.9.6.6 Custom Fill Series

To make entering a particular sequence of data such as a department name or an employee name easier, you can create a custom fill series. A custom fill series can be based on a list of existing items on a worksheet, or you can type the list from scratch. The operation steps are as follows:

(1) Click the Application Menu icon at the top left corner of the screen to open the drop-down list.

(2) Click the Options icon at the bottom right and open the Options dialogue box.

(3) Choose the Custom Lists tab in the dialogue box as shown below:
Choose the New list option in the Custom lists section and enter the new list in the List entries section as shown in Figure 2.9-12.

(5) Click the Add button at the bottom right to add the new list.

(6) Click the OK button to complete the operation.

(7) Enter “Red” in the Spreadsheets and drag the fill handle. The new list you have just added will be applied. The effect is shown below:

![Image of custom fill list]

(8) You can also delete custom list by clicking the Delete button in the Custom Lists tab. Mind that you can’t edit or delete the built-in fill series, such as the fill series for days and months.

### 2.9.7 Hiding and Showing Columns and Rows

If you don’t want other people to see some particular content in your worksheet, you can hide the rows or
columns that contain the content. The steps to hide rows and columns are as follows:

1. Select the rows and columns which you want to hide.

2. Select the **Hide and Unhide** option in the **Rows and Columns** drop-down list. There are four options offered as shown below:

![Figure 2.9-16 The Hide and Unhide drop-down list](image)

3. Choose the **Hide Rows** and **Hide Columns** option to hide the selected rows and columns.

4. Choose the **Unhide Rows** and **Unhide Columns** option to cancel the operation above.

**Skills**: Select the intended rows and columns, right-click the mouse, and select the **Hide** and **Unhide** option in the context menu to perform the hide and unhide function.

### 2.10 Worksheet

You can carry out a series of operations on worksheets, including select, insert, delete, protect, rename, move, copy, set the tab color, and hide and unhide worksheets.
2.10.1 Selecting Sheet

If you want to move, copy, cut, or delete worksheets, you have to select them first. Simply click the worksheet label to select the intended worksheets.

![Figure 2.10-1 Selecting a single sheet](image)

You can hold the `<Shift>` key to select multiple worksheets that are adjacent to one another.

You can hold the `<Ctrl>` key to select multiple worksheets that are non-adjacent to each other.

Select the current worksheet, right-click the mouse, and choose the Select All Sheets option in the context menu to select all sheets. The effect is shown below:

![Figure 2.10-2 Select All Sheets](image)

2.10.2 Inserting Sheet

If you want to insert one or more worksheets, take the following steps:

(1) Select the current worksheet.

(2) Click the Worksheet icon in the Home tab to open the drop-down list. Select the Insert Sheet option as shown below:
The **Insert Sheet** dialogue box will then open and show as below:

![Insert Sheet dialogue box](image)

(3) Enter the number of worksheets you want to create in the **Insert count** enter box.

(4) Choose either the **After current sheet** or the **Before current sheet** option to specify the location where you want to create the new worksheets.

(5) Press the **OK** button to complete the operation.

**Skills:** You can also insert worksheets by the context menu. Select the current worksheet, right-click the mouse, and choose the **Insert Sheet** option in the context menu. The **Insert Sheet** dialogue box will then open. Repeat the operation above to insert new worksheets.

### 2.10.3 Deleting Sheet

If you want to delete one or more worksheets, follow the steps below:

(1) Select the worksheets you want to delete.

(2) Choose the **Delete Sheet** option in the **Worksheet** drop-down list.

(3) If there is data in the current worksheet, the following dialogue box will open.
If you’ve made up your mind to delete the worksheet, you can press the OK button to complete the operation.

**Skills:** You can also delete worksheet by the context menu. Select the worksheets that you want to delete, right-click the mouse, and choose the **Delete Sheet** option in the context menu.

### 2.10.4 Protect Sheet

If you want to protect the worksheet, follow the steps below:

1. Select the worksheets which you want to protect from others.
2. Choose the **Protect Sheet** option in the **Worksheet** drop-down list.
3. The **Protect Sheet** dialogue box will then open and show as below:

![Protect Sheet dialogue box](image)

(4) The password is optional and you can enter it according to your need.

(5) Select or deselect the check boxes offered to specify the operations which other users are allowed to
carry out on the worksheets.

(6) Click the OK button to complete the operation.

2.10.5 Renaming Sheet

By default, Kingsoft Spreadsheets names worksheets by the model of “Sheet + serial number”. In most cases, you would want to rename the worksheets. The following are methods to rename worksheets.

- Double-click the worksheet label and when the label is selected enter the new name. When finished, press the <Enter> key or click any place except the worksheet label to finish the operation.
- Right-click the worksheet label which you want to rename. Select the Rename option in the context menu and enter the new name. Press the <Enter> key or click any place except the worksheet label to finish the operation.
- Select the worksheet label, go to the Home tab, and select the Rename option in the Worksheet drop-down list. After entering the new name, press the <Enter> key or click any place except the worksheet label to finish the operation.

2.10.6 Moving or Copying Sheet

There are two ways to move and copy worksheets: by the Move or Copy Sheet option in the Worksheet drop-down list and by the mouse.

- Move or copy worksheets by the dialogue box.

(1) Select the worksheets that you want to move or copy.

(2) Click the Worksheet icon in the Home tab and select the Move or Copy Sheet option in the drop-down list. The Move or Copy Sheet dialogue box will open and show as below:
(3) In the **To workbook** drop-down box, select the workbook where you want to put your worksheet. If you want to move or copy the selected worksheet into a new workbook, select the **New workbook** option.

(4) Select the worksheet before which you want to insert or copy the intended worksheet in the **Before Sheet** list box.

(5) If you want to copy rather than move the worksheet, select the **Create a copy** check box.

(6) Click the **OK** button to complete the operation.

- Move or copy worksheets by the mouse.

This method is suitable for moving or copying worksheets that are in the same workbook. The steps are as follows:

(1) Select the worksheets that you want to move.

(2) Drag the selected sheets along the row of the sheet tabs to the intended position. There will be a little dark triangle on the top left of the first tab, which indicates the location of the worksheet.

(3) Select the worksheets that you want to copy.

(4) Hold the **<Ctrl>** key and drag the sheets to the intended position.

(5) When the little dark triangle moves to the intended position, first release the mouse button, and then release the **<Ctrl>** key. You can also release them at the same time.
2.10.7 Tab Color

You can set the tab color for the worksheets by the following steps:

(1) Select the worksheets that you want to set the tab color.

(2) Click the Worksheet icon in the Home tab and select the Tab Color option in the drop-down list.

(3) Choose the preferred tab color in the drop-down menu as shown below:
(4) The tab color of the selected worksheets will change into the one you have chosen. The effect is shown as below:

(5) You can choose the No Fill option in the drop-down menu to clear the tab color.
## 2.10.8 Hiding and Showing Sheet

There are two methods to hide or unhide a worksheet:

- Select the worksheet that you want to hide or unhide. Click the **Worksheet** icon and select the **Hide and Unhide** option. Choose the **Hide Sheet** or **Unhide Sheet** option in the drop-down list.
- Select the worksheet that you want to hide or unhide. Right-click the mouse and choose the **Hide** or **Unhide** option in the context menu.

## 2.11 Find and Replace

### 2.11.1 Find

To use the **Find** function, follow the steps below:

1. Click the **Find and Replace** icon in the **Home** tab and select the **Find** option in the drop-down list, or you can press the `<Ctrl+F>` combination. The **Find** dialogue box will then open and show as below:

![Find dialogue box](image)

Figure 2.11-1 The Find dialogue box

2. Input the text you want to find in the **Find what** enter box.
3. Click the **Options** button to unfold the dialogue box where you can set the finding condition in a more specific way.
4. Click the **Find Next** button to locate the next cell which contains the target text.
5. Click the **Find Previous** button to locate the previous cell which contains the target text.
6. Click the **Find All** button and all the data which meet your requirement will be listed.
7. Click the **Close** button to close the dialogue box.
2.11.2 Replace

To use the Replace function, follow the steps below:

1. Click the Find and Replace icon in the Home tab and select the Replace option in the drop-down list, or you can press the <Ctrl+H> combination. The Replace dialogue box will then open and show as below:

![Figure 2.11-2 Replace Tab](image)

2. Input the contents you want to find in the Find what enter box and input the contents you want to replace with in the Replace with enter box.

3. Click the Replace button to replace once.

4. Click the Replace All button to replace all the content in the worksheet.

5. Click the Close button to close the dialogue box.

Tips: You can enter nothing in the Replace with enter box to delete all the contents which you have find.

2.11.3 Go To

You can quickly locate data in the worksheet by the Go To function offered by Kingsoft Spreadsheets. To use the Go To function, follow the steps below:

1. Click the Find and Replace icon in the Home tab and select the Go To option in the drop-down list, or you can press the <Ctrl+G> combination. The Go To dialogue box will then open and show as below:
(2) You can specify the conditions by selecting or deselecting the check boxes in the above dialogue box.
(3) Click the Go To button to locate the cells which meet the conditions you have specified.
(4) Click the Close button to close the dialogue box.

2.11.4 Select Objects

You can easily select objects in the Kingsoft Spreadsheet by the selecting objects mode. Follow the steps below:

(1) Click the Find and Replace icon in the Home tab and choose the Select Objects option in the drop-down list. See below:

(2) When the cursor changes into a arrow-headed cross, you can then select the target objects simply by clicking them.
(3) You can also click and hold the mouse, and then drag the mouse to cover the objects you want to
select. There will be a shadow area with dotted lines as its borders and objects in it will altogether be selected.

## 2.12 Format as Table

Kingsoft Spreadsheets provides the **Format as Table** tab for you to convert a range of cells to a table with its own style. You can emphasize or normalize the First Row, Last Row, Banded Rows, Banded Columns, First Column, Last Column, First Row and Last Row, and First Row and First Column of the table.

To use the theme style in the current worksheet, follow the steps below:

1. Select the cells where you want to use the theme style.
2. Click the arrow of **Format as Table** to open the drop-down list. See below:
(3) Click the preferred theme style in the drop-down list and it will be applied to the selected cells.

### 2.13 Symbol

To insert symbols that are not on your keyboard, such as enclosed characters and copyright symbols, follow the steps below:
(1) Place the insertion point to the place where you want to insert a symbol.

(2) Open the Home tab and click the Symbol icon. The recently used symbols and the available custom symbols will be displayed in the symbol drop-down list.

(3) If the symbol you want to insert is not in the symbol library, select the More Symbols option at the bottom of the symbol list. Then the Symbol dialog box will open and show as below:

![Symbol dialog box]

Figure 2.13-1 The Symbol dialog box

(4) Select the symbol you want from the dialog box and click the Insert button.

3 Insert Tab

3.1 Tables

3.1.1 PivotTable

PivotTables are dynamic tabulations which allow you to quickly combine and compare data to produce tailored information to suit your needs. In pivot tables, by rotating rows and columns, users can view
details from different perspectives. In brief, pivot tables allow users to simplify complicated data and discover an internal model which otherwise would be difficult to find in a disordered list. However, it is recommended to use pivot tables only when you have a long list of complicated data and want to analyze the related details. Otherwise, it is not necessary to use this function.

To apply the PivotTable function, follow the steps below:

(1) Click the **PivotTable** icon in the **Insert** tab.

![The PivotTable icon](image)

(2) In the **Select a range** section of the **Create PivotTable** dialogue box, choose the data range which you want to base your pivot table (If you have already activated a cell in the source data range before performing the first step, Kingsoft Spreadsheets will automatically select that range for you) and the data range will be enclosed by dotted boarders. You can also modify a pivot table that already exists in the spreadsheet. There are two options offered, namely the **New Worksheet** and the **Existing Worksheet**, for you to choose where you want to place the pivot table.

![Create a pivot table](image)

(3) After clicking the **OK** button in the **Create PivotTable** dialogue box, an empty pivot table will
appear in the position you have chosen. You can use the **PivotTable** task window which automatically pops up on the right to put contents into the pivot table you have created. Items presented in the **Field List** section can be dragged to the **Page Area, Column Area, Row Area** and **Data Area** in the **Pivot Table Areas** section. By moving these items to different areas, you can view them in different perspectives. To delete any of them, you can simply move them out of the areas. By this way, you can analyze the detailed information contained in the data range.

![PivotTable](image)

**Figure 3.1-3** Set the pivot table

### 3.1.1.1 PivotTable Tools Tab

After you have created a pivot table in the worksheet, the **PivotTable Tools** tab will appear on the top of the window. See below:
The functions of these tools are as follows:

- **Modify PivotTable**: Click this icon and the **Modify PivotTable** dialogue box will open where you can modify the existing pivot table.

- **Refresh Data**: After you have made changes to the source data, click this icon and the data in the pivot table will be refreshed.

- **Sort**: Click this icon and the **PivotTable Field Advanced Options** dialogue box will open and show as below. In the **AutoSort** section, you can choose to sort the data by default (manually change the item order), in ascending order, and in descending order. Choose the using field in the drop-down list.

You can choose the **Top 10 AutoShow** tab to show the top 10 or other number of items in the pivot table. Choose the using field in the drop-down list.

- **Hide**: Click this icon to hide the items in the pivot table fields.
- **Order**: By choosing options offered in the **Order** drop-down list, you can move the row or column in the pivot table to the beginning or to the end.

  ![Order drop-down list](image)

  Figure 3.1-7 The Order drop-down list

- **Delete**: Click this icon to delete the currently selected pivot table.

- **Show Detail**: Click this icon to show all items of the active field.

- **Hide Detail**: Click this icon to hide all items of the active field.

- **Field Settings**: Click this icon and the **PivotTable Field** dialogue box will open.

  ![PivotTable Field dialogue box](image)

  Figure 3.1-8 The PivotTable Field dialogue box

In the **Subtotals** tab, you can select the options offered to calculate a subtotal.
In the **Display** tab, you can select to display the items which you prefer. Select the **Show items with no data** check box and only those items with no data will be displayed.

When you select a field in the pivot table, you can choose the type of calculation to summarize data in that field. See below:

- **Subtotals**: Click this icon to show or hide subtotals.
- **PivotTable Options**: Click this icon and the PivotTable Options dialogue box will open where you
can specify the settings of the pivot table by selecting or deselecting the check boxes. See below:

- **Hide Field List** and **Show Field List**: Click this icon to hide and show the PivotTable task window at the right side of the screen.

### 3.2 Chart

In order to enhance the explanatory effect of the data and make the data vivid for the reader, you can use chart to display data. Chart is the most intuitive way to analyze data. Kingsoft Spreadsheets can automatically generate various kinds of charts according to the data in the cells, such as the **Column** chart, **Bar** chart, **Line** chart, **Pie** chart, **Area** chart and so on. All these types of charts can easily convert between one another. In the following section we’ll introduce the chart type, chart structure, how to create chart, chart tools tab, and custom chart.

#### 3.2.1 Chart Type

Kingsoft Spreadsheets offers 9 types of charts, and you can choose the appropriate one to best convey what you want to express effectively. They are the **Column** chart, **Bar** chart, **Line** chart, **Pie** chart, **XY(Scatter)** chart, **Area** chart, **Stock** chart, **Radar** chart, and **Combo** chart. You can choose different styles and colors for each type of charts. See below:
Click the **Chart** icon in the Insert tab and the **Insert Chart** dialogue box will open and show as below. You can modify chart settings there.

![Chart Types](image1.png)

**Figure 3.2-1 Chart types**

![Chart Type Dialogue Box](image2.png)

**Figure 3.2-2 Chart Type dialogue box**
3.2.2 Chart Structure

A chart is composed of the chart area and other elements in the area, such as the chart title, legend, axes and so on. Some elements such as the legend and data series can be subdivided into separate elements. The elements of chart are shown as follows:

- **Data Source**: Refers to the data range you select to create charts.
- **Data Series**: Data series are automatically generated by the group of data which is going to be illustrated on the chart. You can choose row data or column data to generate the series.
- **Data Labels**: To quickly identify a data series in a chart, you can add data labels in the chart. By default, the data labels are linked to values in the worksheet. You can set the properties of data labels via the **Data Labels** tab in the **Add Chart Element** drop-down list.
- **Axes**: Axes are lines on the edge of the charts used to measure and compare data. Charts usually have two axes: a vertical value (y) axis, and a horizontal (x) axis.
- **Chart Title**: Chart titles are usually a short description of the chart, and it is usually found at the top center of the chart or aligns with the axes automatically.
- **Legend**: Displays the names of the data series in corresponding patterns and colors.

![Chart Structure](image)

3.2.3 Creating Chart

To create charts, follow the steps below:

1. Select the cells that contain the data you want to plot in a chart. For example, select the cell range as shown below.
(2) Click the **Chart** icon in the **Insert** Tab. The **Insert Chart** dialogue box will pop up.

(3) Select the suitable chart type on the left side of the dialog box. Here we choose the **Clustered Column** in the **Column chart** group. See below:

(4) Click the **OK** button and the original table will appear in the table. See below:
(5) Right click on the table and a menu will pop up. Choose Select Data option in the menu and the Edit Data Source dialogue box will open. See below:

- **Chart Data Source**: The tab is used to modify the data range of the chart. You can select the data
range in the corresponding sections in Figure 3.2-7.

- **Series Creation Direction**: In this section, you can choose *Data of each column* as a series or *Data of each row as a series*. Here we choose *Data of each column as a series*.

- **Legend Entries(series)**: The series tab is used to change the name, values. You can select the series in the corresponding sections in Figure 3.2-7. Choose to add or remove series by the Add and Remove button. Edit the Name, Values areas in the corresponding sections as below:

  ![Edit Series dialog box](image)

  **Figure 3.2-8 The Edit Series dialog box**

- **Axis Labels(Category)**: This section is used to modify the data range of the category axis. Click the Edit button on the upper right corner and the Axis Labels dialogue box will open as below:

  ![Axis Labels dialog box](image)

  **Figure 3.2-9 The Axis Labels dialog box**

- **Advanced Setting**: In this section, you can choose show empty cell as Gaps or Zero. Meanwhile, you can choose Show data in hidden rows and columns or not.

(6) Click the OK button and the effect as below:
Then you can edit the **Chart Title** by double click the chart title area on the table or right click the chart title tab and choose Edit Text in corresponding menu. And you can choose **Font** in the menu to modify font Style, size, font color and so on. The effect as below:
3.2.4 Chart Tools Tab

After you have inserted the chart into the current worksheet, the Chart Tools tab will appear at the top of the screen. See below:

![Figure 3.2-12 The Chart Tools tab](image)

3.2.4.1 Add Chart Element Function

A table contains many of elements, click this icon to add chart elements such as the title, legend, gridlines, and data labels. To add these elements, follow the steps below:

1. Select the table you want to add some elements and click the Add Chart Element icon in the Chart Tool tab. The Add Chart Element drop-down list will open and show as below:

![Figure 3.2-13 The Add Chart Element drop-down list](image)

2. Kingsoft Spreadsheets provides eleven different elements to add.
   - **Axis**: Select the way you prefer to display the primary axis X and Y by the drop-down list of Axis. Axis Y usually displays the values of the data. You can choose to add the Primary Horizontal Axis or the Primary Vertical Axis.
● **Axis Title:** You can enter titles for the category (X) axis, and the category (Y) axis in the corresponding enter box.

● **Chart Title:** You can enter titles above the chart or by the centered overlay style.

● **Data Lables:** You can add labels to data in this tab. There are five styles for user to choose, **None**, **Center**, **Inside End**, **Inside Base**, and **Outside End**. Then choose your preferred style.

● **Data Table:** You can show the data table in the chart by selecting the **Data Table** option in the **Add Chart Element** drop-down list. You can add the data table with legend keys or no legend keys, and by selecting **None** option to cancel the data table in the table.

● **Error Bars:** You can insert the error bars on the current table with three styles: **Standard Error**, **Percentage**, **Standard Deviation**. And by selecting **None** option to cancel the error bars in the table.

● **Gridlines:** You can choose to show or hide the major and minor gridlines in axis X and Y by selecting the “Primary Major Horizontal”, “Primary Major Vertical”, “Primary Minor Horizontal”, “Primary Minor Vertical” options in the drop-down list of **Gridlines**.

● **Legend:** You can choose to show the legend on the Right, left, top or bottom of the table.

● **Trendline:** You can add trendline with four styles: **Linear**, **Exponential**, **Linear Forecast**, **Moving Average**. And by selecting **None** option to cancel the trendline in the table.

### 3.2.4.2 Quick Layout Function

Kingsoft Spreadsheets provides the quick method to change the whole layout of the current table. You can use this function by clicking the **Quick Layout** icon in the **Chart Tools** tab. There are eleven different layout in the drop-down list and you can choose the preferred style to apply to the current table.

### 3.2.4.3 Change Color Function

In general, the inserted table will have the default color. You can customize the color and style by clicking the **Change Color** in the **Chart Tools** tab. Click the arrow of the **Change Color** and the drop-down list Will open, containing Colorful and Monochromatic options. You just choose that you prefer. See below:
3.2.4.4 Switch Row/Column Function

Sometimes, in order to observe the change of data more accurate or due to the need of specific situations, you need to swap the data over the axis. Kingsoft Spreadsheets provides the quick method to achieve this effect by clicking the **Switch Row/Column** icon in the **Chart Tools** tab. Then the data being charted on the X axis will move to the Y axis and vice versa.

3.2.4.5 Change Chart Type Function

Kingsoft Spreadsheets provides **Change Chart Type** Function to quickly change to a different type of chart. To use this function, follow the steps below:

1. Select the table that you want to change to a different type of current chart.
2. Click the **Change Chart Type** icon in the **Chart Tool** tab and the **Change Chart Type** dialog box will open.
3. Then choose the preferred chart type on the left side of the dialog box as figure 3.2-5.
4. Click the **OK** button to insert a new chart on the current worksheet.
5. According to your need, in accordance with the above steps to complete the operation.
3.2.4.6 Move Chart Function

Move chart refers to moving the currently selected tables to another sheet or tab in the workbook. To use this function, follow the steps below:

1. Select the table that you want to moving.
2. Click the Move Chart icon in the Chart Tools tab and the Move Chart dialog box will open. See below:

![Move Chart dialog box]

Figure 3.2-15 The Move Chart dialog box

3. There are two choices for you to choose where you want the chart to be placed (eg. New Sheet, Object In). Here we choose Object In and click the OK button to complete the operation. See below...
Figure 3.2-16 The situation before moving chart

Figure 3.2-17 The effect after moving chart
### 3.2.4.7 Format Function

Kingsoft Spreadsheets provides the quick method to set the format of the current table. To use this function, follow the steps below:

1. Select the table whose format you want to change.
2. Click the **Format** icon in the **Chart Tools** tab. The **Formatting** task window will open and show at the right side of the window. See below:

   ![Formatting task window](image)

   **Figure 3.2-18** The Formatting task window

3. The **CHART OPTIONS** and **TEXT OPTIONS** will be displayed in the Formatting task window. In this section, you can fill whole table or lines of the current cells and add effects for the current table, or adjust size and alignment for the whole table.

**Tips:**

It is quicker to change the format you like by clicking it on the **Home** tab. You also can right-click the table and choose the **Format Chart Area** option to open the **Formatting** task window.
### 3.2.4.8 Reset Style Function

Kingsoft Spreadsheets provides the **Reset Style** function to clear the custom formatting of the selected chart element and back to the overall visual style applied to the chart. This ensures that chart element matches the overall theme of the document.

### 3.3 Picture

If the worksheet only contains raw data and text, it would be boring and without main points. Pictures are very useful in presenting the data, which visually display the contents of the data to the user. If you have pictures which you feel would enhance the demonstration of the data, you can insert these pictures into the worksheet.

To insert pictures in the worksheet, follow the steps below:

1. Click the **Picture** icon in the **Insert** tab. The **Insert Picture** dialogue box will open and show as below:

   ![Insert Picture dialogue box](image)

   **Figure 3.3-1 The Insert Picture dialogue box**

2. Find the picture in the **File Name** search box. Then click the **Open** button and the picture will be inserted in the current worksheet.

   **Tips:** After inserting the picture, the **Picture Tools** tab will show up where you can modify the properties of the picture (more detailed information, see the corresponding chapters in User Manual of Writer 2016)
3.4 Shapes

If inserting pictures are still not enough demonstration, then you can insert shapes. Kingsoft Spreadsheets provides various kinds of shapes which will enrich the data.

To insert Shapes, follow the steps below:

(1) Click the Shapes icon in the Insert tab and the Shapes drop-down list will open. See below:

![Shapes drop-down list]

Figure 3.4-1 The Shapes drop-down list

(2) Click the shape that you prefer. When the cursor changes into a cross, you can draw the shape in the current worksheet.

Tips: After inserting the shape, the Drawing Tools tab will show up where you can modify the properties
of the shape (more detailed information, see the corresponding chapters in User Manual of Writer 2016).

### 3.5 Text Box

Kingsoft Spreadsheets provides two types of text box: **Horizontal** and **Vertical**. In the **Insert** tab, you can select the **Horizontal** or **Vertical** option in the **Text Box** drop-down list. When the cursor changes into a cross, you can drag it to insert the text box in the current worksheet. Then you are free to enter the contents into the inserted text box.

### 3.6 Word Art

Kingsoft Spreadsheets provides a series of WordArt style. To insert WordArt in the worksheet, follow the steps below:

1. Click the **WordArt** icon in the **Insert** tab. There are many styles of wordart in the drop-down list. See below:

   ![WordArt Style](image)

   **Figure 3.6-1 WordArt Style**

2. Choose the WordArt style you prefer. The edit WordArt text box will appear in the worksheet and show as below:

   ![Edit WordArt Text](image)

   **Figure 3.6-2 Edit WordArt Text**

3. Enter the contents in the Text enter box and set the font, size, bold, and italic style for the text.
Tips:
After you have inserted the WordArt in the worksheet, the **WordArt** tab and **Format** tab will appear where you can specify the properties of the WordArt (for more detailed information, see the corresponding chapters in User Manual of Writer 2016).

### 3.7 Header & Footer

You can add header and footer to the worksheet. The steps are as follows:

1. Click the **Header and Footer** icon in the **Insert** tab. The **Page Setup** dialogue box will open and show as below:

   ![Page Setup dialogue box](image)

   **Figure 3.7-1 The Page Setup dialogue box**

2. Open the **Header and Footer** tab where you can customize the header and footer. Click the **Custom Header** button to open the Header dialogue box shown as below:
Enter the contents of the header in the **Left section**, **Center section**, and **Right section** enter box.

- If you need to set the format of the text, put the cursor in the edit box, and then click the **Font** button.

- If you need to insert **Page Number**, **Number of Pages**, **Date**, **Time**, **File**, and **Sheet Name**, put the cursor in the edit box and press the corresponding icon.

- If you need to insert pictures, click the **Insert Picture** icon. If you need to set the format of pictures, put the cursor in the edit box, and click the **Reset Picture** icon.

3. After you have finished all the settings, press **OK** to return to the **Header and Footer** tab where you can preview the effect. **Custom Footer** works the same way as **Custom Header**.

4. Click the **Options** button at the bottom to set the page layout.

5. If you want to print the worksheet, you can click the **Print** button at the bottom to set the print properties in the **Print** dialogue box.
Click the OK button to complete the operation.

### 3.8 Hyperlink

#### 3.8.1 Create Hyperlink

In Kingsoft Spreadsheets, you can establish hyperlinks between cells, and between cells and files, web pages, or even e-mail accounts.

To create hyperlink in the worksheet, follow the steps below:

1. Select the cell where you want to add a hyperlink.
2. Click the Hyperlink icon in the Insert tab. The Hyperlink dialogue box will open and show as below:

![Hyperlink dialogue box](image)

3. Select the target file in the Link to section.
4. Press the OK button to insert the hyperlink between the selected cell and the target file.
5. Click the cell where you’ve added the hyperlink and you can quickly switch to the target file. You can also open the hyperlink by right-clicking the cell and choosing the **Open Hyperlink** option in the context menu.

![Cell with hyperlink](image)
(6) To edit the hyperlink you have created, right-click the cell and choose the **Edit Hyperlink** option in the context menu. The **Edit Hyperlink** dialogue box will open where you can modify the target file.

To meet the different requirements of the customers, Kingsoft Spreadsheets provides a hyperlink control tab, which means you can input information about the Internet or the network path. You can decide whether to automatically change internet links into hyperlinks in the worksheet. The steps are shown as follows:

1. Open the **Application menu at the top left corner. Click the Options button at the lower right corner.**

2. **Select the Edit tab in the Options dialogue box. See below:**

![Figure 3.8-3 The Edit tab](image)

3. In the **Edit Settings section, select the Replace Internet and network paths with hyperlinks as you type check box and the hyperlinks will be activated by default.**

### 3.8.2 Group Create and Cancel Hyperlinks

If the web page address or the e-mail address are not automatically changed into hyperlinks in a document, you can convert them altogether. Kingsoft volume conversion tool allows you to perform this function so as to facilitate your document or e-mail needs. The steps are as follows:

1. **Only the URL and e-mail addresses can be converted into hyperlinks. Therefore select the cell range**
whose contents need to be converted into hyperlinks.

(2) Click the **Format** icon in the **Home** tab and choose the **Convert Text to Hyperlink** option in the drop-down list. Then the URL and e-mail addresses will be converted into hyperlinks. See below:

![Figure 3.8-4 Convert Text to Hyperlink](image)

If you want to remove the hyperlink you have created, right-click the target cell range and choose the **Remove Hyperlink** option in the context menu. See below:

![Figure 3.8-5 Remove Hyperlink](image)

### 3.9 Symbol

You can insert symbol in Kingsoft Spreadsheets. The steps are as follows:

(1) Select the cell where you want to insert the symbol.

(2) Click the **Symbol** icon in the **Insert** tab. The drop-down list will open and show as below:
Figure 3.9-1 The Symbol drop-down list

(3) Click the symbol that you prefer in the **Recently Used Symbols** section and the **Custom Symbols** section. The symbol will be inserted in the worksheet.

(4) You can also choose the **More Symbols** option at the bottom to open the **Symbol** dialogue box. See below:
(5) Choose the symbols in the Symbols and Special Characters tab.

(6) You can also customize symbols in the Custom Symbols tab, e.g. move and remove the custom symbols, or even reset the symbol tool bar.

(7) Click the Insert button to insert the symbol. Or click the Cancel button to cancel the operation.

3.10 Equation

You can insert equation in Kingsoft Spreadsheets, follow the steps below:

(1) Select the cell or cell range where you want to insert the equation.

(2) Click the Equation icon in the Insert tab.

(3) The Equation Editor will open where you can edit the equation. See below:
(4) Close the **Equation Editor** and the equation you have edited will be inserted to the selected cell or cell range.

### 3.11 Insert Object

The steps to insert an object in the worksheet are shown as follows:

1. Click the **Object** icon in the Insert tab and the **Insert Object** dialogue box will open and show as below:
There are two options to insert objects:

- **Create New**: Insert object directly. Select the type of the object you want to insert in the **Object type** roll-down list. Kingsoft Spreadsheets supports a variety of object types, such as Microsoft Excel Chart, Microsoft Excel Sheet, Microsoft Office Excel 2007 Workbook and so on.

- **Create from file**: Insert objects which already exist in the system.

(2) Select the **Display as icon** check box. Then the inserted object will be displayed as an icon.

(3) Press the **OK** button to complete the operation.

### 3.12 Insert File Object

To insert file object in the worksheet, follow the steps below:

(1) Click the **File Object** icon in the **Insert** tab. The **Insert File Object** dialogue box will open and show as below:
(2) Find the target file and click the **Open** button to insert the file in the worksheet.

### 3.13 Insert AutoShape

You can also insert AutoShape in Kingsoft Spreadsheets, such as Label, Group Box, Button, etc.

- **Label**: Click this icon to insert label in the worksheet. Double click the label you have inserted and set the size, properties, and control in the **Format AutoShape** dialogue box. See below:

- **Group Box**: Click this icon to insert group box in the worksheet. Double click the group box you have inserted and set the size, properties, and control in the **Format AutoShape** dialogue box.

- **Button**: Click this icon to insert button in the worksheet. Double click the button you have inserted and enter the macro name and description in the corresponding enter box of the **Assign Macro** dialogue box. See below:
Check Box: Click this icon to insert check box in the worksheet. Double click the check box you have inserted and set the colors and lines, size, properties, and control in the **Format AutoShape** dialogue box.

Option Button: Click this icon to insert option button in the worksheet. Double click the option button you have inserted and set the colors and lines, size, properties, and control in the **Format AutoShape** dialogue box.

List Box: Click this icon to insert list box in the worksheet. Double click the list box you have inserted and set the size, properties, and control in the **Format AutoShape** dialogue box.

Combo Box: Click this icon to insert combo box in the worksheet. Double click the combo box you have inserted and set the size, properties, and control in the **Format AutoShape** dialogue box.

Scroll Bar: Click this icon to insert scroll bar in the worksheet. Double click the scroll bar you have inserted and set the size, properties, and control in the **Format AutoShape** dialogue box.

Spinner: Click this icon to insert spinner in the worksheet. Double click the spinner you have inserted and set the size, properties, and control in the **Format AutoShape** dialogue box.

Control Properties: Click this icon to open the **Format AutoShape** dialogue box and set the properties of the selected AutoShape.

Edit Code: Click this icon to open Microsoft Visual Basic and edit the selected form code.
3.14 Screen Grap

To quickly add a snapshot of any window that is open on your desktop to your document, follow the steps below:

(1) Click the Screen Grap icon in the Insert tab. The drop-down list will open and show as below:

![Screen Grap icon](image)

Figure 3.14-1 The Assign Macro dialogue box

(2) Choose the Screen Grap option in the drop-down list or press <Ctrl+Alt+X> and you can add a snapshot of the current window that is open on your desktop.

(3) Choose the Hide Current Window when Grabbing Screen option in the drop-down list or press <Ctrl+Alt+C> and you can add a snapshot of the window that can not contain the current open window on your desktop.

4 Page Layout Tab

4.1 Page Setup

You can use the Page Setup dialogue box to set the Page, Margins, Header and Footer, and Sheet to meet your requirements.

4.1.1 Margins

To set the margins of the worksheet, follow the steps below:

(1) Click the Margins icon in the Layout tab. The Margins tab in the Page Setup dialogue box is shown as below:
(2) In the **Margins** tab you can:

- Control the spacing of margins by editing the Top, Bottom, Left and Right options.
- Control the margins between the header and the top of the page, or the footer and the bottom of the page, by inputting numbers in the Header and Footer spinner.
- In the Center on page section, set the way you want your table to be centered. You can select Horizontally or Vertically options according to your requirements.

(3) Click the **OK** button to complete the operation. Or click the **Cancel** button to exit.

### 4.1.2 Orientation

There are two ways to set the orientation of the page:

- Click the **Orientation** icon in the **Layout** tab and choose the **Portrait** or **Landscape** option in the drop-down list. See below:
Click the Size icon in the Layout tab. The Page Setup dialogue box will open. Select the Page tab shown as below:

In the Orientation section, select the Portrait or Landscape option button.

### 4.1.3 Size

To set the size of the page, follow the steps below:

1. Click the Size icon in the Layout tab and the Page Setup dialogue box will open. Select the Page tab. See below:
(3) Select the size of the paper in the **Paper Size** drop-down list.

(4) Press **OK** to complete the operation.

### 4.1.4 Print Area

To set the print area, follow the steps below:

1. Click the **Print Area** icon in the **Layout** tab and choose the **Set Print Area** option in the drop-down list. See below:

![Figure 4.1-5 The Print Area drop-down list](image)

2. Then you can drag the mouse to select the area need to print.

3. Open the Application menu at the top left corner of the screen. Choose the **Print** option in the drop-down list. Then you can see the effect of the printing area.

4. Choose the **Clear Print Area** option in the drop-down list to clear the print area you have set.
4.1.5 Print Titles

In order to print the titles on each page in spreadsheet documents, Kingsoft provides the title printing function. To use this function, follow the steps below:

1. Click the Print Title icon in the Page Layout tab and the Page Setup dialogue box will open. Select the Sheet tab. See below:

   ![Figure 4.1-6 Print titles](image)

   Figure 4.1-6 Print titles

   (2) In the Sheet tab, there are five functions which are shown as follows:

   - **Rows to repeat at top**: If you want to print the column label on every page, you have to select the row number in which your column label is located in the **Rows to repeat at top** section.

   - **Columns to repeat at top**: If you want to print the row label on every page, you have to select the column number in which your row label is located in the **Columns to repeat at top** section.

   - **Print Gridlines**: You can choose whether or not to print the grid lines, and you can also choose to print only the horizontal grid lines or the vertical grid lines. When you choose not to print the grid lines, you can print the spreadsheet much faster.

   - **Print Row and column headings**: Select the **Row and column headings** check box to print the row number and column labels.

   - **Page order**: You can choose the print order of pages: **Down, then over** or **Over, then down**.

2. Press OK to complete the operation.
4.1.6 Breaks

If you want to print your worksheet in several pages, you can insert breaks in the worksheet. Follow the steps below:

1. Select the row where you want to insert the break.
2. Click the Breaks icon in the Page Layout tab and select the Insert Page Break option in the Breaks drop-down list. See below:

![Insert Page Break]

Figure 4.1-7 The Insert Page Break option

3. Then you can see there is a dotted line above the row you have selected. See below:

![Dotted line above selected row]

Figure 4.1-8 The dotted line

4. Open the Application menu at the top left corner and choose Print Preview in the drop-down list. Then you can see the effect of the breaks.

5. If you want to cancel the break you have inserted, select the same row and choose Delete Page Break in the Breaks drop-down list. See Figure 4.1-7.

6. If you want to reset all the breaks you have inserted in the worksheet, select Reset All Page Breaks in the Breaks drop-down list. See Figure 4.1-7. Then all the page breaks in the worksheet will be deleted.

4.1.7 Page Zoom

You can set the zoom scaling when you print the work sheet. If the sheet is too small, you can increase its percentage. If the sheet is too large, you can decrease its percentage to fit it in one page.

To zoom the page, do as follows:
(1) Click the **Page Zoom** icon in the **Page Layout** tab and there are many options in the drop-down list, such as **No Zoom**, **Fit Sheet on One Page**, **Fit All Columns on One Page**, **Fit All Rows on One Page** and **Zoom**. See below:

![Figure 4.1-9 the page zoom drop-down list](image)

(2) You can also click the Custom **Zoom(X)** options and the **Page Setup** dialogue box will open. Select the **Page** tab. See below:

![Figure 4.1-10 Zoom the page](image)

(3) You can adjust the print scaling in the **Scaling** section. Enter the proportion you want to zoom the worksheet in the **Adjust to** enter box. Kingsoft Spreadsheets supports worksheet zoom from 10% to 400%.

(4) Enter the number of page that you want the worksheet to fit to in the **Fit to** enter box.

(5) Enter the width of the worksheet in the **wide by** enter box.

**Tips:**

When you select **Adjust to**, the system will automatically ignore the manually created breaks. Change the values in the **Adjust to** enter box, the spreadsheet will then be printed according to your needs.
4.2 Arrange

4.2.1 Arrange Object Orders

To rearrange the object orders in Kingsoft Spreadsheets, follow the steps below:

(1) Select the objects which you want to rearrange orders

(2) Use the Bring Forward and Send Backward drop-down list in the Page Layout tab. See below:

![Bring Forward and Send Backward](image)

Figure 4.2-1 Bring Forward and Send Backward

The function of these options are as follows:

- Bring Forward: Bring an object one step closer to the front.
- Bring to Front: Bring an object to the front of the stack.
- Send Backward: Send an object one step toward the back.
- Send to Back: Send an object to the back of the stack.

**Tips:** Select the object you want to move. If the object is hidden, select any object, and then press `<Tab>` or `<Shift+Tab>` until the object you want is selected.

4.2.2 Align

4.2.2.1 Align Objects

Kingsoft Spreadsheets provides 6 align options: Align Left, Align Center, Align Right, Align Top, Align Middle, and Align Bottom. The operation steps are shown as follows:

(1) Select the objects you want to align.

(2) In the Page Layout tab, select the options in the Align drop-down list. See below:
4.2.2.2 Distribution

Kingsoft Spreadsheets provides two distribution methods: Distribute Horizontally and Distribute Vertically. If objects are arranged in equal distance, you can use the horizontal and vertical distribution methods. The operation steps are shown as follows:

(1) To distribute objects, you have to select multiple objects. Hold <Ctrl> to select multiple objects.

(2) In the Page Layout tab, select Distribute Horizontally or Distribute Vertically in the Align drop-down list. See Figure 4.2-2.

4.2.2.3 Object Size Adjustment

If you want to adjust the size of the inserted objects, you can do as follows:

- Equal Height: Select the desired objects. In the Page Layout tab, select Equal Height in the Align drop-down list. The selected objects will be adjusted to the same height.

- Equal Width: Select the desired objects. In the Page Layout tab, select Equal Width in the Align
drop-down list. The selected objects will be adjusted to the same width.

- Equal Size: Select the desired objects. In the Layout tab, select Equal Size in the Align drop-down list. The selected objects will be adjusted to the same size.

4.2.2.4 Snap to Grid

If you want the object you have inserted to snap to the grid, you can do as follows:

(1) Select the desired objects.

(2) In the Page Layout tab, open the Align drop-down list and select the Snap to Grid option. See Figure 4.2-2.

(3) Then you can use the mouse to drag the objects to align them to the grid.

(4) If you want to cancel the operation, select the Snap to Grid option again in the Align drop-down list.

4.2.2.5 Show Grid

In Kingsoft Spreadsheets, you can set whether or not to show grid.

If you want to show grid, select the Show Grid option in the Align drop-down list of the Layout tab. See Figure 4.2-2.

If you don’t want to show grid, select the Show Grid one more time in the Align drop-down list.

4.2.3 Group

You can group shapes, pictures, and other objects. Grouping allows you to rotate, flip, move, and re-size all shapes and objects at the same time as if they were a single shape or object. The operation steps are as follows:

(1) You can hold <Ctrl> when clicking to select multiple objects.

(2) In the Page Layout tab, select Group in the Group drop-down list. See below:

![Group drop-down list](image)

Figure 4.2-3 The Group drop-down list

(3) Select Ungroup in the Group drop-down list to ungroup the multiple objects.
4.2.4 Rotate

In order to allow you to freely edit pictures, Kingsoft Spreadsheets provides Rotate Left 90°, Rotate Right 90°, Flip Horizontal and Flip Vertical options. The operation steps are shown as follows:

1. Select the pictures which you want to edit.
2. In the Layout tab, click the Rotate icon to open the drop-down list. Choose the rotate style that you prefer according to your needs. See below:

![Rotate dropdown list](image)

Figure 4.2-4 The Rotate drop-down list

4.3 Themes

In Kingsoft Spreadsheets, you can easily change the overall design of the entire document, including colors, fonts and effects. These functions are as follow:

- **Themes**: Click the themes icon and you can choose the themes that you prefer in the drop-down list and show as below:
Figure 4.3-1 The Themes drop-down list

- **Colors**: Click this icon to change the colors of current theme in the drop-down list.

- **Fonts**: Click this icon to change the fonts of current theme in the drop-down list.

- **Effects**: Click this icon to change the effect of current theme in the drop-down list.

## 5 Formulas Tab

Formulas are equations that are used to analyze and calculate the numeric values. You can use a formula, which usually begins with an equal mark (=), to perform some simple calculations such as addition, subtraction, multiplication and division. Meanwhile, formulas can include any of the following elements:
functions, references, operators, and constants. If you want to input formula in a cell of a worksheet, you can input a combination of these elements.

### 5.1 Formulas Grammar

In Kingsoft Spreadsheets, whether a cell contains a formula or not is based on whether it starts with “=”. Specifically, a formula is usually composed of the following elements:

- = equality sign.
- Numbers: 0–9 or cell addresses (numbers contained in the cells).
- Other arguments that can be referred to by formulas or functions.
- ( ): to set the priorities.
- Operators: to connect data. There are three different types of operators in Kingsoft Spreadsheets: arithmetic, comparison, and text and reference. See below:

<table>
<thead>
<tr>
<th>Category</th>
<th>Operator</th>
<th>Feature</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arithmetic</td>
<td>+ (plus sign)</td>
<td>Addition</td>
<td>The calculate orders are: the data in “()” has higher calculation priorities; multiplication and division first, and then addition and subtraction; for the same level of operations, calculate from left to right.</td>
</tr>
<tr>
<td></td>
<td>- (minus sign)</td>
<td>Subtraction</td>
<td></td>
</tr>
<tr>
<td></td>
<td>* (asterisk)</td>
<td>Multiplication</td>
<td></td>
</tr>
<tr>
<td></td>
<td>/ (forward slash)</td>
<td>Division</td>
<td></td>
</tr>
<tr>
<td></td>
<td>% (percent sign)</td>
<td>Percent</td>
<td></td>
</tr>
<tr>
<td></td>
<td>^ (caret)</td>
<td>Exponentiation</td>
<td></td>
</tr>
<tr>
<td>Comparison</td>
<td>=</td>
<td>Equal to</td>
<td>You can compare two values with the operators on the left. When two values are compared by using the operators, the result is a logical value, i.e. TRUE or FALSE.</td>
</tr>
<tr>
<td></td>
<td>&gt;</td>
<td>Greater than</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;</td>
<td>Less than</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;&gt;</td>
<td>Not equal to</td>
<td></td>
</tr>
</tbody>
</table>
### Create Formulas

Formulas are equations that perform calculations on values in your worksheet. You can create formulas by using constants, calculations operators, cell references, and names that you have defined. The operation steps are as follows:

1. Click the cell where you want to create a formula.
2. Input constants, functions, operators, cell references and so on.
3. Press `<Enter>` after inputting the formula.

### Input Formulas

To input formulas in a cell, follow the steps below:

<table>
<thead>
<tr>
<th>Category</th>
<th>Operator</th>
<th>Feature</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>&amp;</td>
<td>Text concatenation</td>
<td>Use the ampersand (&amp;) to join, or concatenate one or more text strings to produce a single piece of text.</td>
</tr>
<tr>
<td>Reference</td>
<td>: (colon)</td>
<td>Range operator</td>
<td>Produces one reference to all the cells between two references, including the two references. (For example, A1:A3)</td>
</tr>
<tr>
<td></td>
<td>, (comma)</td>
<td>Union operator</td>
<td>Combines multiple references into one reference. (For example, SUM (A1:A3, B1:B5)</td>
</tr>
<tr>
<td></td>
<td>(space)</td>
<td>Intersection operator</td>
<td>Produces the reference to the intersecting cells of two references. (For example, A1:A3 A2:B5)</td>
</tr>
</tbody>
</table>

Table 5.1-1 Operators offered in Kingsoft Spreadsheets
(1) Select the cell where you want to input the formula.
(2) In the edit bar, input “=” and the specified contents of the formula.
(3) Press <Enter> or click ✓ in the edit bar.
(4) If you want to cancel the contents, click ×.

5.1.3 Copy a Formula

The operation steps are as follows:

(1) Select the cell that you want to copy.
(2) Right-click the cell and select Copy in the context menu.
(3) Right-click the cell to which you want to copy the formula and select Paste Special in the context menu. Then the Paste Special dialogue box will open and show as below:

![Paste Special dialogue box](image)

Figure 5.1-1 Paste Special dialogue box

(4) In the Paste section, select Formulas.
(5) Press OK to complete the operation.

5.2 Function Library

Kingsoft spreadsheets provides a number of functions for you. You can create formulas by using these functions, so that you can conveniently and quickly calculate data in the spreadsheet. In Kingsoft
Spreadsheets there mainly are nine kinds of functions, namely Financial, Logical, Text, Date and Time, Lookup and Reference, Math and Trig, Statistical, Engineering, and Information.

### 5.2.1 Insert Function

If you insert a function in Kingsoft Spreadsheets, it will automatically be saved in the **Insert Function** dialogue box. Next time when you open the **Insert Function** dialogue box, the function you used will be listed at the top of Recently Used functions. For example, if you insert ADDRESS in the spreadsheet, then when you open the dialogue box next time, it will be listed in the recently used functions category, shown as follows:

![Insert Function dialogue box](image)

*Figure 5.2-1 The Insert Function dialogue box*

**Tips:** In Kingsoft Spreadsheets, there are only seven functions kept by default in the **Insert Function** dialogue box. If there are more, the system will automatically delete them. But the most recently used one
will always be listed at the top.

### 5.2.2 Use Functions in the Table

The syntax to call a function is the same. The basic format is: = function name (argument 1, argument 2, argument 3,...). Here are some examples:

1. Click the cell where you want to input a function. Cell C9 is taken as an example in the following illustration.

![Figure 5.2-2 Select the cell](image)

2. Click the **Insert Function** icon in the **Formulas** tab. The **Insert Function** dialogue box will open and show as below:

   ![Insert Function Dialogue Box](image)
(3) Select SUM in the Choose a function list box and press OK.

(4) Then the Function Arguments dialogue box will open where you can input or select the desired cells in the Number 1 input box. Press OK. See below:

(5) The function is inserted successfully and the result is displayed as below:
Figure 5.2-5 The calculated result

**Tips:** Click the Recently Used icon in the Formulas tab and the recently used formulas will be listed in the drop-down list for you to choose.

Click the All icon in the Formulas tab and all the formulas which Kingsoft Spreadsheets provide will be listed in alphabetical order in the drop-down list for you to choose.

## 5.2.3 Function Category

### 5.2.3.1 Financial Functions

There are 27 financial functions in Kingsoft Spreadsheets. See below:

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCRINT (date of issue, value date, transaction date, rate, face value)</td>
<td>Returns the interests of the securities whose interests should be paid off once the time is due.</td>
</tr>
<tr>
<td>ACCRINTM (date of issue, maturity date, rate, face value, basis)</td>
<td>Returns the interests of the securities whose interests should be paid off once the time is due.</td>
</tr>
<tr>
<td>AMORDEGRC (cost, data_purchased, first_period, salvage, period)</td>
<td>Returns the depreciation for each settlement period.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>AMORLINC</td>
<td>Returns the prorated linear depreciation of an asset for each accounting period.</td>
</tr>
<tr>
<td>COUPDAYBS</td>
<td>Returns the number of days from the beginning of the coupon period to the settlement data.</td>
</tr>
<tr>
<td>COUPDAYSNC</td>
<td>Returns the number of days from the settlement data to the next coupon data.</td>
</tr>
<tr>
<td>CUMIPMT</td>
<td>Returns the cumulative interest paid between start_period and end_period.</td>
</tr>
<tr>
<td>CUMPRINC</td>
<td>Returns the cumulative principal paid on a loan between start_period and end_period.</td>
</tr>
<tr>
<td>DB</td>
<td>Returns the depreciation of an asset for a specified period using the fixed-declining balance method.</td>
</tr>
<tr>
<td>DDB</td>
<td>Returns the depreciation of an asset for a specified period using the double-declining balance method or some other method you specify.</td>
</tr>
<tr>
<td>FV</td>
<td>Returns the future value of an investment based on periodic, constant payments, and a constant interest rate.</td>
</tr>
<tr>
<td>IPMT</td>
<td>Returns the amount of interest payment for an investment within a given period, based on periodic, constant payments, and a constant interest rate.</td>
</tr>
<tr>
<td>IRR</td>
<td>Returns the internal rate of return that is represented by numbers for a series of cash flows.</td>
</tr>
<tr>
<td>ISPMT</td>
<td>Calculates the interest that should be paid within a specific investment period.</td>
</tr>
<tr>
<td>MIRR</td>
<td>Returns the modified internal rate of return for the given</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>reinvest_rate()</td>
<td>periodic cash flows. MIRR takes both the cost of investment and the interest received on reinvestment of cash into account.</td>
</tr>
<tr>
<td>NPER (rate, pmt, pv, fv, type)</td>
<td>Returns the number of payment periods for an investment based on periodic, constant payments, and a constant interest rate.</td>
</tr>
<tr>
<td>NPV (rate,value1,value2, ...)</td>
<td>Returns the net present value of an investment, using a discount rate and a series of future periodic payments and income.</td>
</tr>
<tr>
<td>PMT (rate, nper, pv, fv, type)</td>
<td>Returns the payment for a loan based on constant payments and a constant interest rate.</td>
</tr>
<tr>
<td>PPMT (rate, per, nper, pv, fv)</td>
<td>Returns for a given period the payment on the principal for an investment based on periodic, constant payments, and a constant interest rate.</td>
</tr>
<tr>
<td>PRICE (transaction date, maturity date, rate, yld, redemption)</td>
<td>Returns the price per $ 100 face value of a security that pays periodic interest.</td>
</tr>
<tr>
<td>PV (rate, nper, pmt, fv, type)</td>
<td>Returns the present value of an investment, calculating from a series of future payments.</td>
</tr>
<tr>
<td>RATE (nper, pmt, pv, fv, type)</td>
<td>Returns the interest rate per period of an annuity.</td>
</tr>
<tr>
<td>SLN (cost, salvage, life)</td>
<td>Returns the linear depreciation of an asset per period.</td>
</tr>
<tr>
<td>SYD (cost, salvage, life, period)</td>
<td>Returns the sum-of-years' digits depreciation of an asset for a specified period, which is based on its cost, salvage value and anticipated life.</td>
</tr>
<tr>
<td>VDB (cost, salvage, life, start_period, end_period)</td>
<td>Returns the depreciation of an asset for an given period or partial period using the double-declining balance method or some other method you specify.</td>
</tr>
<tr>
<td>XIRR (values, dates, )</td>
<td>Returns the internal rate of return for a schedule of cash flows.</td>
</tr>
</tbody>
</table>
function | explanations
---|---
guess) | flows.

YIELD (transaction data, maturity data, rate, face value, redemption) | Returns the yields of regular payment securities.

<table>
<thead>
<tr>
<th>5.2.3.2 Logical Functions</th>
</tr>
</thead>
</table>

There are 7 logical functions in Kingsoft Spreadsheets. See below:

<table>
<thead>
<tr>
<th>function name</th>
<th>explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND (logical1, logical2, ...)</td>
<td>Returns FALSE if any of the arguments is FALSE; returns TRUE only if all arguments are TRUE.</td>
</tr>
<tr>
<td>FALSE</td>
<td>Returns the logical value FALSE.</td>
</tr>
<tr>
<td>IF (logical_test, value_if_true, value_if_false)</td>
<td>Checks whether a condition is met, and returns one value if TRUE, and another value if FALSE.</td>
</tr>
<tr>
<td>IFERROR (value, value_if_error)</td>
<td>Returns the values you specify if the calculated result of the formula is an error and the calculated result otherwise.</td>
</tr>
<tr>
<td>NOT (logical)</td>
<td>Reverses the logical value of the argument.</td>
</tr>
<tr>
<td>OR (logical1, logical2, ...)</td>
<td>Returns TRUE if any of the arguments are TRUE; returns FALSE only if all the arguments are FALSE.</td>
</tr>
<tr>
<td>TRUE</td>
<td>Returns the logical value TRUE.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>5.2.3.3 Text Functions</th>
</tr>
</thead>
</table>

There are 34 text functions in Kingsoft Spreadsheets. See below:

<table>
<thead>
<tr>
<th>function name</th>
<th>explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Function Name</strong></td>
<td><strong>Explanations</strong></td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ASC (text)</td>
<td>Converts full-width (doubt-byte) characters to half-width (single-byte) characters. Use with doubt-byte character sets (DBCS).</td>
</tr>
<tr>
<td>CHAR (number)</td>
<td>Returns the character specified by the code number from the character set for your computer.</td>
</tr>
<tr>
<td>CLEAN (text)</td>
<td>Removes all nonprintable characters from text.</td>
</tr>
<tr>
<td>CODE (text)</td>
<td>Returns a numerical code for the first character in a text string in the character set used by your computer.</td>
</tr>
<tr>
<td>CONCATENATE (text 1, text 2,...)</td>
<td>Joins several text strings into one text string.</td>
</tr>
<tr>
<td>DOLLAR (number, decimals)</td>
<td>Converts a number to text, using the currency format (US dollar) and specified digits.</td>
</tr>
<tr>
<td>EXACT (text 1, text 2)</td>
<td>Returns TRUE if one string is exactly equal to the other string (EXACTLY means case-sensitive); returns FALSE otherwise.</td>
</tr>
<tr>
<td>FIND (find_text, within_text, start_num)</td>
<td>Returns the starting position of one text string within another (case-sensitive, and wildcard characters are not allowed).</td>
</tr>
<tr>
<td>FINDB (find_text, within_text, start_num)</td>
<td>Searches another text string’s starting location in one text string. FINDB is case-sensitive and doesn’t allow to use wildcard. Use double-byte characters (DBCS).</td>
</tr>
<tr>
<td>FIXED (number, decimals, no_commas)</td>
<td>Rounds a number to the specified number of decimals in decimal format and returns the result as text with or without commas.</td>
</tr>
<tr>
<td>LEFT(text, num_chars)</td>
<td>Returns the characters with a specified number from the first character of a text string.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>LEFTB (text, bytes number)</td>
<td>Returns the specified number of characters from the leftmost appointed position of a text string. Use with double-byte character set (DBCS).</td>
</tr>
<tr>
<td>LEN (text)</td>
<td>Returns the length of a text string.</td>
</tr>
<tr>
<td>LENS (text)</td>
<td>Returns the number of characters in a text. Use with double-byte character set (DBCS).</td>
</tr>
<tr>
<td>LOWER (text)</td>
<td>Returns the lowercase version of a text string.</td>
</tr>
<tr>
<td>MID (text, start_num, num_chars)</td>
<td>Returns the characters with a specific length from a given starting position in a text string.</td>
</tr>
<tr>
<td>MIDB (text, start_num, bytes number)</td>
<td>Returns the specified number of characters from the appointed location of a text string. Use with double-byte character set (DBCS).</td>
</tr>
<tr>
<td>NUMBERSTRING (number, method)</td>
<td>Convert a number to a chinese string.</td>
</tr>
<tr>
<td>PROPER (text)</td>
<td>Capitalizes the initials of all the words.</td>
</tr>
<tr>
<td>REPLACE (old_text, start_num, num_chars, new_text)</td>
<td>Replaces characters within a text string with another different text string.</td>
</tr>
<tr>
<td>REPLACEB (old_text, start_num, bytes number, new_text)</td>
<td>Replaces characters within a text string with another different text string. Use with double-byte character set (DBCS).</td>
</tr>
<tr>
<td>REPT (text, number_times)</td>
<td>Returns repetitions of string for specified times. You can use REPT to fill a cell with a text string repeatedly.</td>
</tr>
<tr>
<td>RIGHT (text, num_chars)</td>
<td>Returns the specified number of characters from the end of a text string.</td>
</tr>
<tr>
<td>RIGHTB (text, byte number)</td>
<td>Returns the specified number of characters from the last character of a text string. Use with double-byte character set (DBCS).</td>
</tr>
<tr>
<td>SEARCH (find_text, within_text,</td>
<td>Returns the first found location of the specified</td>
</tr>
</tbody>
</table>
### Function Name | Explanations
--- | ---
start_num) | character or string with in a text string, reading from left to right (not case-sensitive).

SEARCHB (find_text, within_text, start_num) | Returns the first found location of the specified character or string with in a text string, reading from left to right (not case-sensitive). Use with double-byte character set (DBCS).

SUBSTITUTE (text, old_text, new_text, instance_num) | Replaces part of the old text with new text in a string.

T (number) | Returns the text that the value refers to.

TEXT (value, format_text) | Returns value as a string with the specified format.

TRIM (text) | Returns text with only single spaces between words.

UPPER (text) | Returns the upper-case version of a text string.

USDOLLAR (number, decimals) | Converts a number to text using currency format and the specified digits.

VALUE (text) | Returns the numeric value of a text string.

WIDECHAR (text) | Converts half-width (single-byte) characters to full-width (double-byte) characters. Use with double-byte character set (DBCS).

### 5.2.3.4 Date and Time

Kingsoft Spreadsheet provides 21 functions in Date and Time category. See below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE (year, month, day)</td>
<td>Returns the number that represents the date in WPS Spreadsheet date-time code.</td>
</tr>
<tr>
<td>DATEDIF (start_date, end_date,</td>
<td>Counts the number of days, months, or years</td>
</tr>
<tr>
<td>Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>comparison unit)</td>
<td>between the two dates.</td>
</tr>
<tr>
<td>DATEVALUE (date_text)</td>
<td>Converts the date in the form of text to a number that represents the date in WPS Spreadsheets date-time code.</td>
</tr>
<tr>
<td>DAY (serial_number)</td>
<td>Returns the day of the month; a number from 1 to 31.</td>
</tr>
<tr>
<td>DAYS360 (start_date, end_date, method)</td>
<td>Returns the number of days between two dates based on a 360-day year (30 days a month and 12 months a year), which is used in some accounting calculations. Use this function to help compute payments if your accounting system is based on 30 days a month and 12 months a year.</td>
</tr>
<tr>
<td>EDATE (start date, number of months)</td>
<td>Returns the serial number that represent the date which is the indicated number of months before or after a date (the start_date). Use this function to calculate the maturity dates that fall on the same day of the month as the date of issue.</td>
</tr>
<tr>
<td>EOMONTH (start_date, number of months)</td>
<td>Returns the serial number for the last day of the month which is the indicated number of the month before or after the start date. Use this function to calculate the maturity dates that fall on the last day of the month.</td>
</tr>
<tr>
<td>HOUR (serial_number)</td>
<td>Returns the hour as a number from 0 (12:00 A.M) to 23 (11:00 P.M).</td>
</tr>
<tr>
<td>MINUTE (serial_number)</td>
<td>Returns the minute; a number from 0 to 59.</td>
</tr>
<tr>
<td>MONTH (serial_number)</td>
<td>Returns the month; a number from 1 (January) to 12 (December).</td>
</tr>
<tr>
<td>NETWORKDAYS (start_date,</td>
<td>Returns the number of the workdays (except</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><code>end_date, holidays()</code></td>
<td>weekends and legal holidays) between two dates.</td>
</tr>
<tr>
<td><code>NOW</code></td>
<td>Returns the current date and time formatted as a date and time.</td>
</tr>
<tr>
<td><code>SECOND (serial_number)</code></td>
<td>Returns the second, a number from 0 to 59.</td>
</tr>
<tr>
<td><code>TIME (hour, minute, second)</code></td>
<td>Converts hours, minutes, seconds given as numbers to a WPS Spreadsheets serial number, formatted with a time format.</td>
</tr>
<tr>
<td><code>TIMEVALUE (time_text)</code></td>
<td>Converts a text time to an WPS Spreadsheets serial number for a time.</td>
</tr>
<tr>
<td><code>TODAY</code></td>
<td>Returns the current date formatted as a date.</td>
</tr>
<tr>
<td><code>WEEKDAY (serial_number, return_type)</code></td>
<td>Returns a number from 1 to 7 identifying the day of the week of a date.</td>
</tr>
<tr>
<td><code>WEEKNUM (serial_number, return_type)</code></td>
<td>Returns the number identifying the order of the week of a year.</td>
</tr>
<tr>
<td><code>WORKDAY (start_date, number of days, holidays)</code></td>
<td>Returns a date that is the indicated number of workdays (except weekends and holidays) before or after a date (start date). Use this function when calculating the invoice due dates, expected delivery date, and the number of days you have worked.</td>
</tr>
<tr>
<td><code>YEAR (serial_number)</code></td>
<td>Returns the year of a date; an integer in the range 1900-9999.</td>
</tr>
<tr>
<td><code>YEARFRAC (start_date, end_date, basis)</code></td>
<td>Returns the percentage of the year represented by the number of whole days between two dates (start date and end date). Use this function to identify the proportion of a whole year’s benefits or obligations under some specified condition.</td>
</tr>
</tbody>
</table>

Table 5.2-4 Date and Time Functions
## 5.2.3.5 Lookup and Reference Functions

There are 19 lookup reference functions in Kingsoft Spreadsheets. See below:

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADDRESS (row_num, column_num, abs_num, al, sheet_text)</td>
<td>Creates a cell reference as text according to the specified row and column numbers.</td>
</tr>
<tr>
<td>AREAS (reference)</td>
<td>Returns the number of areas in a reference. An area is a range of contiguous cells or a single cell.</td>
</tr>
<tr>
<td>CHOOSE (index_num, value1, value2, ...)</td>
<td>Returns a value from the list of arguments based on the given index number.</td>
</tr>
<tr>
<td>COLUMN (reference)</td>
<td>Returns the column number of a reference.</td>
</tr>
<tr>
<td>COLUMNS (array)</td>
<td>Returns the number of columns in an array or reference.</td>
</tr>
<tr>
<td>EVALUATE (formula_text)</td>
<td>Evaluates a formula or expression which is expressed in text and returns the result.</td>
</tr>
<tr>
<td>GETPIVOTDATA (data field, pivot table area)</td>
<td>Extracts data stored in a PivotTable.</td>
</tr>
<tr>
<td>HLOOKUP (lookup_value, table_array, row_num, range_lookup)</td>
<td>Searches for a value in the top row of a table or an array of values, and then returns a value in the same column from a row you specify in the table or array (The table is ascending by default).</td>
</tr>
<tr>
<td>HYPERLINK (hyperlink position, display text)</td>
<td>Creates a shortcut or jump that opens a document stored on a network server, Intranet, or Internet.</td>
</tr>
<tr>
<td>INDEX (array, row_num, column_num, area_num)</td>
<td>Returns the value of an element in a table or an array, selected by the row and column number indexes.</td>
</tr>
<tr>
<td>INDIRECT (ref_text, al)</td>
<td>Returns the reference specified by a text string.</td>
</tr>
<tr>
<td>LOOKUP (lookup_value, table_array, row_num, range_lookup)</td>
<td>Looks up a value either from a one-row or</td>
</tr>
</tbody>
</table>
## Function Name | Explanations
---|---
lookup_vector, result_vector | one-column range or from an array.
MATCH (lookup_value, lookup_array, match_type) | Returns the relative position of an item in an array that matches a specified value in a specified order.
OFFSET (reference, rows, cols, height, width) | Returns a reference to a range that is a given number of rows and columns from a given reference.
ROW (reference) | Returns the internal row number of a specified reference.
ROWS (array) | Returns the number of rows in a reference or array.
RTD (progID, server) | Retrieves real-time data from a program that supports COM automation.
TRANSPOSE (array) | Returns a horizontal range of cells as a vertical range, or vice versa. Transpose must be entered as an array formula in the range that has the same number of rows or columns respectively with those of an array. Use transpose to shift vertical or horizontal orientation of an array in a worksheet.
VLOOKUP (lookup_value, table_array, col_index_num, range_lookup) | Searches for a specified value in the leftmost column of a table and returns a value in the current row from a column you have specified.

Table 5.2-5 Lookup and Reference Functions

### 5.2.3.6 Math and Trigonometry Functions

There are 60 math and trigonometry functions in Kingsoft Spreadsheets. See below:
<table>
<thead>
<tr>
<th>Function Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS (number)</td>
<td>Returns the absolute value of a number, a number without its sign.</td>
</tr>
<tr>
<td>ACOS (number)</td>
<td>Returns the arccosine of a number, in radians in the range from 0 to Pi. The arccosine is the angle whose cosine is the Number.</td>
</tr>
<tr>
<td>ACOSH (num_digits)</td>
<td>Returns the inverse hyperbolic cosine of a number.</td>
</tr>
<tr>
<td>ASIN (number)</td>
<td>Returns the arcsine of a number within radians from -Pi/2 to Pi/2.</td>
</tr>
<tr>
<td>ASINH (number)</td>
<td>Returns the inverse hyperbolic sine of a number. The inverse hyperbolic sine is the value whose hyperbolic sine is number, so ASINH(SINE&lt;number&gt;) equals number.</td>
</tr>
<tr>
<td>ATAN (number)</td>
<td>Returns the arctangent of a number in radians from -Pi/2 to Pi/2.</td>
</tr>
<tr>
<td>ATAN2 (x_num, y_num)</td>
<td>Returns the arctangent of the specified x_ and y_ coordinates, in radians between -Pi and Pi (excluding -Pi).</td>
</tr>
<tr>
<td>ATANH</td>
<td>Returns the inverse hyperbolic tangent of a number. The number must between -1 to 1 (excluding -1 and 1). The inverse hyperbolic tangent is the value whose hyperbolic tangent is number, so ATANH(TANH&lt;number&gt;) equals number.</td>
</tr>
<tr>
<td>CEILING (number, significance)</td>
<td>Rounds a number up, to the nearest integer, or to the nearest multiple of significance.</td>
</tr>
<tr>
<td>COMBIN (number, number chosen)</td>
<td>Returns the number of combinations for a given number of items.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>COS (number)</td>
<td>Returns the cosine of a given angel.</td>
</tr>
<tr>
<td>COSH (number)</td>
<td>Returns the hyperbolic cosine of a number.</td>
</tr>
<tr>
<td>DEGREES (angle)</td>
<td>Converts radians to degrees.</td>
</tr>
<tr>
<td>EVEN (number)</td>
<td>Rounds positive numbers up and negative numbers down to the nearest even integers.</td>
</tr>
<tr>
<td>EXP (number)</td>
<td>Returns e raised to the power of a given number.</td>
</tr>
<tr>
<td>FACT (number)</td>
<td>Returns the factorial of a number. The factorial of a number is equal to 1<em>2</em>3*...* number.</td>
</tr>
<tr>
<td>FACTDOUBLE (number)</td>
<td>Returns the double factorial of a number.</td>
</tr>
<tr>
<td>FLOOR (number, significance)</td>
<td>Rounds numbers down, toward zero, to the nearest multiple of significance.</td>
</tr>
<tr>
<td>GCD (number 1, number 2, ...)</td>
<td>Returns the greatest common divisors of two or more integers.</td>
</tr>
<tr>
<td>INT (number)</td>
<td>Rounds a number down to the nearest integer.</td>
</tr>
<tr>
<td>LCM (number 1, number 2, ...)</td>
<td>Returns the least common multiples of two or more integers.</td>
</tr>
<tr>
<td>LN (number)</td>
<td>Returns the natural logarithm of a number.</td>
</tr>
<tr>
<td>LOG (number, base)</td>
<td>Returns the logarithm of a number to the base you specify.</td>
</tr>
<tr>
<td>LOG10 (number)</td>
<td>The LOG10 function returns the base-10 logarithm of a number.</td>
</tr>
<tr>
<td>MDETERM (array)</td>
<td>Returns the matrix determinant of a number.</td>
</tr>
<tr>
<td>MINVERSE (array)</td>
<td>Returns the reverse matrix for the matrix stored in an array.</td>
</tr>
<tr>
<td>MMULT (array1, array 2)</td>
<td>Returns the matrix product of two arrays. The result is that the array has the same number of</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>MOD (number, divisor)</td>
<td>Returns the remainder after the number is divided by a divisor.</td>
</tr>
<tr>
<td>MROUND (number, significance)</td>
<td>Returns a given number rounded to a special multiple.</td>
</tr>
<tr>
<td>MULTINOMIAL (number 1, number 2, ...)</td>
<td>Returns the ratio of the factorial of a sum of values to the product of factorials.</td>
</tr>
<tr>
<td>ODD (number)</td>
<td>Rounds positive numbers up and negative numbers down to the nearest odd integers.</td>
</tr>
<tr>
<td>PI</td>
<td>The PI function returns the value of Pi, 3.14159265358979, accurate to 15 digits.</td>
</tr>
<tr>
<td>POWER (number, power)</td>
<td>The POWER function returns the result of a number raised to a power.</td>
</tr>
<tr>
<td>PRODUCT (number1,...)</td>
<td>The PRODUCT function multiplies all the numbers given as arguments.</td>
</tr>
<tr>
<td>QUOTIENT (dividend, divisor)</td>
<td>Returns the integer portion of a division and discard the remainder of a division.</td>
</tr>
<tr>
<td>RADIANS (angle)</td>
<td>The RADIANS function converts degrees to radians.</td>
</tr>
<tr>
<td>RAND</td>
<td>The RAND function returns an evenly distributed random real number greater than or equal to 0 and less than 1 (changes on recalculation).</td>
</tr>
<tr>
<td>RANDBETWEEN (bottom, top)</td>
<td>Returns a random integer number between the two numbers you have specified.</td>
</tr>
<tr>
<td>ROMAN (number, type)</td>
<td>Converts an Arabic number to Roman, as text.</td>
</tr>
<tr>
<td>ROUND (number, num_digits)</td>
<td>Rounds a number to a specified number of</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ROUNDUP (number, num_digits)</td>
<td>Rounds a number up, away from 0.</td>
</tr>
<tr>
<td>SERIESUM (x, n, m, coefficients)</td>
<td>Returns the sum of a power series.</td>
</tr>
<tr>
<td>SIGN (number)</td>
<td>Returns the sign of a number. Returns 1 if the number is positive, zero (0) if the number is 0, and -1 if the number is negative.</td>
</tr>
<tr>
<td>SIN (number)</td>
<td>Returns the sine of the given angle.</td>
</tr>
<tr>
<td>SINH (number)</td>
<td>Returns the hyperbolic sine of a number.</td>
</tr>
<tr>
<td>SQRT (number)</td>
<td>Returns the square root of a number.</td>
</tr>
<tr>
<td>SQRTPI (number)</td>
<td>Returns the square root of a number which has been multiplied by Pi.</td>
</tr>
<tr>
<td>SUBTOTAL (function_number, ref1, ref2, ...)</td>
<td>Returns a subtotal in a list or database.</td>
</tr>
<tr>
<td>SUM (number1, number2 ...)</td>
<td>Returns the sum of all the numbers in a range of cells.</td>
</tr>
<tr>
<td>SUMIF (range, criteria, sum_range)</td>
<td>Sum the cells that meet the given criteria.</td>
</tr>
<tr>
<td>SUMIFS (sum range, range 1)</td>
<td>Adds the cells specified by a given set of conditions or criteria.</td>
</tr>
<tr>
<td>SUMPRODUCT (array1, array2, array3, ...)</td>
<td>Multiplies the corresponding data in the given arrays and returns the sum of those products.</td>
</tr>
<tr>
<td>SUMSQ (number 1, number 2)</td>
<td>Returns the sum of the squares of all the arguments. The arguments may vary as numbers, arrays, names, or references to cells which contain numbers.</td>
</tr>
<tr>
<td>SUMX2MY2 (array1, array2)</td>
<td>Returns the sum of differences of squares of corresponding values in two arrays.</td>
</tr>
<tr>
<td>SUMX2PY2 (array1, array2)</td>
<td>Returns the sum of sum squares of</td>
</tr>
</tbody>
</table>
### Math and Trigonometry Functions

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUMXMY2 (array 1, array 2)</td>
<td>Returns the sum of squares of differences of corresponding values in two arrays.</td>
</tr>
<tr>
<td>TAN (number)</td>
<td>Returns the tangent of the given angle.</td>
</tr>
<tr>
<td>TANH (number)</td>
<td>Returns the hyperbolic tangent of a number.</td>
</tr>
<tr>
<td>TRUNC (number, num_digits)</td>
<td>Returns an integer by removing decimal part of the number.</td>
</tr>
</tbody>
</table>

Table 5.2-6 Math and Trigonometry Functions

### 5.2.3.7 Statistical Functions

Click the More Functions icon in the Formulas tab, and choose the Statistical option in the drop-down list. There are 85 statistical functions in Kingsoft Spreadsheets. See below:

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVEDEV (number1,number2, ...)</td>
<td>Returns the average of the absolute deviations of data points from their mean. It is a measure of the variability in a data set.</td>
</tr>
<tr>
<td>AVERAGE (number1,number2, ...)</td>
<td>Returns the average (arithmetic mean) of its arguments, which can be numbers, names, arrays or references that contain numbers.</td>
</tr>
<tr>
<td>AVERAGEA (number1,number2, ...)</td>
<td>Returns the average (arithmetic mean) of the given arguments, including numbers, names, arrays or references. Evaluate text and FALSE in argument as 0; TRUE in argument as 1.</td>
</tr>
<tr>
<td>AVERAGEIF (range, criteria, average range)</td>
<td>Find average (arithmetic mean) for the cells specified by a given condition or criteria.</td>
</tr>
<tr>
<td>AVERAGEIFS (average_range, range 1)</td>
<td>Find average (arithmetic mean) for the cells specified by a given condition or criteria.</td>
</tr>
<tr>
<td>BETADIST (value x, alpha, beta, lower)</td>
<td>Returns the cumulative beta probability density</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>bound of the x range, upper bound of the x range</td>
<td>function.</td>
</tr>
<tr>
<td>BETAINV (distribution probability, alpha, beta, lower bound of the x range, upper bound of the x range)</td>
<td>Returns the inverse of the cumulative beta probability density function(BETADIST).</td>
</tr>
<tr>
<td>BINOMDIST (number_s, trials, probability_s, returns the cumulative distribution function)</td>
<td>Returns the individual term binomial distribution probability.</td>
</tr>
<tr>
<td>CHIDIST (number, degrees of freedom)</td>
<td>Returns the one-tailed probability of the chi-squared distribution. The c2 distribution is associated with a c2test.Use the c2 test to compare observed and expected values.</td>
</tr>
<tr>
<td>CHIINV (distribution probability, degrees of freedom)</td>
<td>Returns the inverse of the one-tailed probability of the chi-squared distribution.</td>
</tr>
<tr>
<td>CHITEST (actual range, expected range)</td>
<td>Returns the test for independence.</td>
</tr>
<tr>
<td>CONFIDENCE (alpha, standard_dev, number_sample)</td>
<td>Returns the confidence interval for a population mean, using a normal distribution.</td>
</tr>
<tr>
<td>CORREL (array 1, array 2)</td>
<td>Returns the correlation coefficient between two data sets.</td>
</tr>
<tr>
<td>COUNT (value1, value2, ...)</td>
<td>Returns the number of cells containing numbers and of numbers in the list of arguments.</td>
</tr>
<tr>
<td>COUNTA (value1, value2, ...)</td>
<td>Counts the number of cells that are not empty.</td>
</tr>
<tr>
<td>COUNTBLANK (range)</td>
<td>Counts empty cells in a specified range of cells.</td>
</tr>
<tr>
<td>COUNTIF (range, criteria)</td>
<td>Counts the number of cells within a range that meet the given condition.</td>
</tr>
<tr>
<td>COUNTIFS (range1, criteria 1)</td>
<td>Counts the number of cells specified by a given set of conditions or criteria.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>COVAR (array 1, array 2)</td>
<td>Returns covariance, the average of the products of deviations for each data point pair. Use covariance to determine the relationship between two data sets.</td>
</tr>
<tr>
<td>CRITBINOM (trials, probability_s, alpha)</td>
<td>Returns the smallest value for which the cumulative binomial distribution is greater than or equal to a criterion value.</td>
</tr>
<tr>
<td>DEVSQ (number 1, number 2)</td>
<td>Returns the sum of squares of deviations of a data set from their sample mean.</td>
</tr>
<tr>
<td>EXPONDIST (x, x, return the cumulative distribution function)</td>
<td>Returns the exponential distribution.</td>
</tr>
<tr>
<td>FDIST (value x, degrees_freedom 1, degrees_freedom 2)</td>
<td>Returns the F probability distribution. Use this function to determine whether two data sets have different degrees of diversity.</td>
</tr>
<tr>
<td>FINV (distribution probability, degrees_freedom 1, degrees_freedom 2)</td>
<td>Returns the inverse of the F probability distribution.</td>
</tr>
<tr>
<td>FISHERERINV (number)</td>
<td>Returns the inverse of the Fisher transformation. If y = FISHER(x), then FISHERINV(y) = x</td>
</tr>
<tr>
<td>FORECAST (x, known_y’s, known_x’s)</td>
<td>Calculates or predicts a future value by using the existing values.</td>
</tr>
<tr>
<td>FREQUENCY (data array, bins array)</td>
<td>Calculates how often values occur within a range of values and then returns a vertical array of numbers having one more element than Bins_array.</td>
</tr>
<tr>
<td>FTEST (array 1, array 2)</td>
<td>Returns the result of an F-test, the one-tailed probability that the variances in Array1 and Array2 are not equal.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>GAMMADIST (number, alpha, beta, return the cumulative distribution function)</td>
<td>Array2 are not significantly different..</td>
</tr>
<tr>
<td>GAMMAINV (distribution probability, alpha, beta)</td>
<td>Returns the inverse of the gamma cumulative distribution.</td>
</tr>
<tr>
<td>GAMMALN (number)</td>
<td>Returns the natural logarithm of the gamma function, ( \Gamma(x) ).</td>
</tr>
<tr>
<td>GEOMEAN (number 1, number 2)</td>
<td>Returns the geometric mean of an array or range of positive numeric data.</td>
</tr>
<tr>
<td>GROWTH (known_y’s, known_x’s, new_x’s, const)</td>
<td>Predicts the exponential growth by using existing data.</td>
</tr>
<tr>
<td>HARMMEAN (number 1, number 2)</td>
<td>Returns the harmonic mean of a data set. The harmonic mean is the reciprocal of the arithmetic mean of reciprocals.</td>
</tr>
<tr>
<td>HYPGEOMDIST (sample_s, number sample, population_s, number population)</td>
<td>Returns the hypergeometric distribution.</td>
</tr>
<tr>
<td>INTERCEPT (known_y’s, known_x’s)</td>
<td>Calculates the point at which a line will interest the y-axis by using the existing x-values and y-values.</td>
</tr>
<tr>
<td>KURT (number 1, number 2)</td>
<td>Returns the kurtosis of a data set.</td>
</tr>
<tr>
<td>LARGE (array, k)</td>
<td>Returns the k-th largest value in a data set.</td>
</tr>
<tr>
<td>LINEST (known_y’s, known_x’s, const, stats)</td>
<td>Returns the parameters of a linear trend.</td>
</tr>
<tr>
<td>LOGEST (known_y’s, known_x’s, const, stats)</td>
<td>Returns statistics that describe a linear trend matching known data points, by fitting a straight line.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>LOGINV (distribution probability, arithmetic average, standard deviation)</td>
<td>Returns the inverse of the cumulative lognormal distribution function of x, where ln(x) is the normal distribution of parameters mean and standard_dev.</td>
</tr>
<tr>
<td>LOGNORMDIST (number, arithmetic mean, standard deviation)</td>
<td>Returns the cumulative lognormal distribution of x, where ln(x) is normally distributed with parameters Mean and Standard_dev.</td>
</tr>
<tr>
<td>MAX (number 1, number 2, ...)</td>
<td>Returns the largest value in a set of arguments (ignore text values and logical values).</td>
</tr>
<tr>
<td>MAXA (number 1, number 2, ...)</td>
<td>Returns the largest value in a list of arguments. Does not ignore logical values and text.</td>
</tr>
<tr>
<td>MEDIAN (number 1, number 2, ...)</td>
<td>Returns the median of the given numbers.</td>
</tr>
<tr>
<td>MIN (number 1, number 2, ...)</td>
<td>Returns the smallest number in a set of arguments (ignore text values and logical values).</td>
</tr>
<tr>
<td>MINA (number 1, number 2, ...)</td>
<td>Returns the smallest value in a list of arguments. Does not ignore logical values and text.</td>
</tr>
<tr>
<td>MODE (number 1, number 2, ...)</td>
<td>Returns the most frequently occurring, or repetitive, value in an array or range of data.</td>
</tr>
<tr>
<td>NEGBINOMDIST (number_f, number_s, probability_s)</td>
<td>Returns the negative binomial distribution, the probability that where will be Number_f failure before the Number_s-th success, with Probability_s of a success.</td>
</tr>
<tr>
<td>NORMDIST (number, arithmetic mean, standard deviation, return the cumulative distribution function)</td>
<td>Returns the normal cumulative distribution for the specified mean and standard deviation.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>NORMINV (distribution probability, arithmetic mean, standard deviation)</td>
<td>Returns the inverse of the normal cumulative distribution for the specified mean and standard deviation.</td>
</tr>
<tr>
<td>NORMSDIST (number)</td>
<td>Returns the standard normal cumulative distribution function with a mean of zero and a standard deviation of one.</td>
</tr>
<tr>
<td>NORMSINV (distribution probability)</td>
<td>Returns the inverse of the standard normal cumulative distribution function with a mean of zero and a standard deviation of one.</td>
</tr>
<tr>
<td>PEARSON (array 1, array 2)</td>
<td>Returns the Pearson product moment correlation, r, a dimensionless index that ranges from -1.0 to 1.0 inclusive.</td>
</tr>
<tr>
<td>PERCENTILE (array, percent)</td>
<td>Returns the k-th percentile of values in a range.</td>
</tr>
<tr>
<td>PERCENTRANK (array, number, num_digits)</td>
<td>Returns the rank of a value in a data set as a percentage (0..1, exclusive) of the data set.</td>
</tr>
<tr>
<td>PERMUT (number, number_chosen)</td>
<td>Returns the number of permutations for a given number of objects selected from the total objects.</td>
</tr>
<tr>
<td>POISSON (number, arithmetic mean, return the cumulative distribution function )</td>
<td>Returns the Poisson distribution.</td>
</tr>
<tr>
<td>PROB (x_range, prob_range, lower bound of the x range, upper bound of the x range)</td>
<td>Returns the probability that values in a range which are between two limits.</td>
</tr>
<tr>
<td>QUARTILE (array, quartile)</td>
<td>Returns the quartile of a data set.</td>
</tr>
<tr>
<td>RANK (number, ref, order)</td>
<td>Returns the rank of a number in a list of numbers; its size relative to other values in the list.</td>
</tr>
<tr>
<td>RANK.AVG(number,ref,order)</td>
<td>Returns the rank of a number in a list of</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>RANK.EQ(number,ref,order)</td>
<td>Returns the rank of a number in a list of numbers; its size relative to other values in the list; if more than one value has the same rank, the average rank is returned.</td>
</tr>
<tr>
<td>RSQ (known_y’s, known_x’s)</td>
<td>Returns the square of the Pearson product moment correlation coefficient.</td>
</tr>
<tr>
<td>SKEW (number 1, number 2)</td>
<td>Returns the skewness of a distribution: a characterization of the degree of asymmetry of a distribution around its mean.</td>
</tr>
<tr>
<td>SLOPE (known_y’s, known_x’s)</td>
<td>Returns the slope of the linear regression line through data points in known_y’s and known_x’s.</td>
</tr>
<tr>
<td>SMALL (array, k)</td>
<td>Returns the k-th smallest value in a data set.</td>
</tr>
<tr>
<td>STANDARDIZE (number, arithmetic average, standard deviation)</td>
<td>Returns a normalized value from a distribution characterized by mean and standard_dev.</td>
</tr>
<tr>
<td>STDEV (number 1, number 2, ...)</td>
<td>Calculates standard deviation based on a sample (ignore text values and logical values).</td>
</tr>
<tr>
<td>STDEVA (number 1, number 2)</td>
<td>Estimates standard deviation based on a sample. Does not ignore logical values and text.</td>
</tr>
<tr>
<td>STDEVP (number 1, number 2, ...)</td>
<td>Calculates standard deviation based on the entire population given as arguments (ignore text values and logical values).</td>
</tr>
<tr>
<td>STDEVPA (number 1, number 2)</td>
<td>Calculates standard deviation based on the entire population. Does not ignore logical values and text.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>STEYX (known_y’s, known_x’s)</td>
<td>Returns the standard deviation of the predicted y-value for each x in the regression.</td>
</tr>
<tr>
<td>TDIST (value x, degrees of freedom, one/two-tailed(1/2) distribution)</td>
<td>Returns the percentile(probability) for the Student t-distribution, which is used in the hypothesis testing of small sample data sets.</td>
</tr>
<tr>
<td>TINV (distribution probability, degrees of freedom)</td>
<td>Returns the t-value of the Student's t-distribution as a function of the probability and the degrees of freedom.</td>
</tr>
<tr>
<td>TREND (known_y’s, known_x’s, new_x’s, not force the coefficient to be 0)</td>
<td>Returns the linear increasing amount based on the current data.</td>
</tr>
<tr>
<td>TRIMMEAN (array, percent)</td>
<td>Returns the mean of the interior of a data set.</td>
</tr>
<tr>
<td>TTEST (array 1, array 2, tails, type)</td>
<td>Returns the probability associated with a Student's t-test.</td>
</tr>
<tr>
<td>VAR (number 1, number 2, ...)</td>
<td>Estimates variance based on a sample (ignore text values and logical values).</td>
</tr>
<tr>
<td>VARA (number 1, number 2, ...)</td>
<td>Estimates variance based on a sample (does not ignore text values and logical values in the sample).</td>
</tr>
<tr>
<td>VARP (number 1, number 2, ...)</td>
<td>Calculates variance based on the entire population (ignore text values and logical values).</td>
</tr>
<tr>
<td>VARPA (number 1, number 2, ...)</td>
<td>Calculates variance based on the entire population, including numbers, text, and logical values.</td>
</tr>
<tr>
<td>WEIBULL (number, alpha, beta, returns the cumulative distribution function)</td>
<td>Returns the Weibull distribution.</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------</td>
</tr>
<tr>
<td>ZTEST (array, sample standard deviation, u0)</td>
<td>Returns the one-tailed probability-value of a z-test.</td>
</tr>
</tbody>
</table>

Table 5.2-7 Statistic functions

### 5.2.3.8 Engineering Functions

Click the More Functions icon in the Formulas tab, and choose the Engineering option in the drop-down list. There are 39 engineering functions in Kingsoft Spreadsheets. See below:

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>BESSELI (lambda, n)</td>
<td>Returns the modified Bessel function In(x).</td>
</tr>
<tr>
<td>BESSELJ (lambda, n)</td>
<td>Returns the Bessel function Jn(x).</td>
</tr>
<tr>
<td>BESSELK (lambda, n)</td>
<td>Returns the modified Bessel function Kn(x).</td>
</tr>
<tr>
<td>BESSELY (lambda, n)</td>
<td>Returns the Bessel function Yn(x).</td>
</tr>
<tr>
<td>BIN2DEC (binary number)</td>
<td>Converts a binary number to decimal.</td>
</tr>
<tr>
<td>BIN2HEX (binary number, places)</td>
<td>Converts a binary number to hexadecimal.</td>
</tr>
<tr>
<td>BIN2OCT (binary number, places)</td>
<td>Converts a binary number to octal.</td>
</tr>
<tr>
<td>COMPLEX (real_num, I_num, suffix)</td>
<td>Converts real and imaginary coefficients into a complex number.</td>
</tr>
<tr>
<td>CONVERT (number, from_unit, to_unit)</td>
<td>Converts a number from one measurement system to another.</td>
</tr>
<tr>
<td>DEC2BIN (decimal number, places)</td>
<td>Converts a decimal number to binary.</td>
</tr>
<tr>
<td>DEC2HEX (decimal number, places)</td>
<td>Converts a decimal number to hexadecimal.</td>
</tr>
<tr>
<td>DEC2OCT (decimal number, places)</td>
<td>Converts a decimal number to octal.</td>
</tr>
<tr>
<td>DELTA (number)</td>
<td>Tests whether two values are equal.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ERF (integral lower bound, integral upper bound)</td>
<td>Returns the error function whose integral is between lower_limit and upper_limit.</td>
</tr>
<tr>
<td>ERFC (integral lower bound)</td>
<td>Returns the complementary ERF function whose integral between x and infinity.</td>
</tr>
<tr>
<td>GESTEP (number, alpha)</td>
<td>Returns 1 if number ≥ step and 0 (zero) otherwise.</td>
</tr>
<tr>
<td>HEX2BIN (hex, places)</td>
<td>Converts a hexadecimal number to binary.</td>
</tr>
<tr>
<td>HEX2DEC (hex)</td>
<td>Converts a hexadecimal number to decimal.</td>
</tr>
<tr>
<td>HEX2OCT (hex, places)</td>
<td>Converts a hexadecimal number to octal.</td>
</tr>
<tr>
<td>IMABS (Inumber)</td>
<td>Returns the absolute value (modulus) of a complex number.</td>
</tr>
<tr>
<td>IMAGINARY (Inumber)</td>
<td>Returns the imaginary coefficient of a complex number.</td>
</tr>
<tr>
<td>IMARGUMENT (Inumber)</td>
<td>Returns the argument $\theta$ (theta), an angle expressed in radians.</td>
</tr>
<tr>
<td>IMCONJUGATE (Inumber)</td>
<td>Returns the complex conjugate of a complex number.</td>
</tr>
<tr>
<td>IMCOS (Inumber)</td>
<td>Returns the cosine of a complex number.</td>
</tr>
<tr>
<td>IMDIV (plural 1, plural 2)</td>
<td>Returns the quotient of two complex numbers.</td>
</tr>
<tr>
<td>IMEXP (Inumber)</td>
<td>Returns the exponential of a complex number.</td>
</tr>
<tr>
<td>IMLN (Inumber)</td>
<td>Returns the natural logarithm of a complex number.</td>
</tr>
<tr>
<td>IMLOG10 (Inumber)</td>
<td>Returns the base-10 logarithm of a complex number.</td>
</tr>
<tr>
<td>IMLOG2 (Inumber)</td>
<td>Returns the base-2 logarithm of a complex number.</td>
</tr>
<tr>
<td>IMPOWER (Inumber, power)</td>
<td>Returns a complex number raised to an integer power.</td>
</tr>
<tr>
<td>IMPRODUCT (Inumber 1, Inumber 2)</td>
<td>Calculates the products of complex numbers in x+yi or x+yj text format.</td>
</tr>
<tr>
<td>IMREAL (Inumber)</td>
<td>Returns the real coefficient of a complex number.</td>
</tr>
<tr>
<td>IMSIN (Inumber)</td>
<td>Returns the sine of a complex number.</td>
</tr>
<tr>
<td>IMSQRT (Inumber)</td>
<td>Returns the square root of a complex number.</td>
</tr>
<tr>
<td>IMSUB (plural 1, plural 2)</td>
<td>Returns the difference between two complex numbers.</td>
</tr>
<tr>
<td>IMSUM (Inumber 1, Inumber 2)</td>
<td>Returns the sum of complex numbers.</td>
</tr>
</tbody>
</table>
OCT2BIN (octal number, places)  Converts an octal number to binary.
OCT2DEC (octal number)  Converts an octal number to decimal.
OCT2HEX (octal number, places)  Converts an octal number to hexadecimal.

Table 5.2-8 Engineering Functions

5.2.3.9 Information Functions

Click the More Functions icon in the Formulas tab, and choose the Information option in the drop-down list. There are 17 information functions in Kingsoft Spreadsheets. See below:

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>CELL (info_type, ref)</td>
<td>Returns information about the formatting, location, or contents of the first cell, according to the sheet's reading order, in a reference.</td>
</tr>
<tr>
<td>ERROR.TYPE (error_val)</td>
<td>Returns a number corresponding to the given error value, or returns the #N/A if no error exists.</td>
</tr>
<tr>
<td>INFO(info_type)</td>
<td>Returns information about the current operating environment.</td>
</tr>
<tr>
<td>ISBLANK (value)</td>
<td>Returns TRUE if a value refers to an empty cell, and returns FALSE otherwise.</td>
</tr>
<tr>
<td>ISERR (value)</td>
<td>Returns TRUE if the value is any error value except #N/A, and returns FALSE otherwise.</td>
</tr>
<tr>
<td>ISERROR (value)</td>
<td>Returns TRUE if the value is an error value and returns FALSE otherwise.</td>
</tr>
<tr>
<td>ISEVEN (number)</td>
<td>Returns TRUE if the number is even and returns FALSE otherwise.</td>
</tr>
<tr>
<td>ISLOGICAL (value)</td>
<td>Returns TRUE if the value is a logical value and returns FALSE otherwise.</td>
</tr>
<tr>
<td>ISNA (value)</td>
<td>Returns TRUE if the value is the #N/A error value and...</td>
</tr>
<tr>
<td>Function Name</td>
<td>Explanations</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ISNONTEXT (value)</td>
<td>Returns TRUE if the value is not text and FALSE otherwise.</td>
</tr>
<tr>
<td>ISNUMBER (value)</td>
<td>Returns TRUE if the value is a number and FALSE otherwise.</td>
</tr>
<tr>
<td>ISODD (number)</td>
<td>Returns TRUE if the number is odd and FALSE otherwise.</td>
</tr>
<tr>
<td>ISREF (value)</td>
<td>Returns TRUE if the value is a reference and FALSE otherwise.</td>
</tr>
<tr>
<td>ISTEEXT (value)</td>
<td>Returns TRUE if the value is text and FALSE otherwise.</td>
</tr>
<tr>
<td>N (value)</td>
<td>Returns a value converted to a number.</td>
</tr>
<tr>
<td>NA</td>
<td>Returns the error value #N/A, an abbreviation of “value not available”.</td>
</tr>
<tr>
<td>PHONETIC(ref)</td>
<td>Extract the phonetic character of the text string.</td>
</tr>
<tr>
<td>TYPE (value)</td>
<td>Returns a number indicating the data type of a value.</td>
</tr>
</tbody>
</table>

Table 5.2-9 Information Functions

5.3 AutoSum

Kingsoft Spreadsheets provides **AutoSum** (automatic summary) function. This makes it more convenient and easy to calculate data in rows and columns. You can select calculation options in the **AutoSum** drop-down list.

5.3.1 Sum of row(s)

The operation steps are as follows:

(1) Select the rows which you want to sum. See below:
In the Formulas tab, click the AutoSum icon and select Sum in the AutoSum drop-down list.

The result will be displayed in the cell to the right of the selected row. See below:
5.3.2 Sum of Column(s)

The operation steps are as follows:

(1) Select the columns which you want to sum. See below:

![Figure 5.2-9 Sum of a column](image)

(2) In the Formulas tab, click the AutoSum icon and select Sum in the AutoSum drop-down list. See Figure 5.2-7.

(3) The result will be displayed in the cell at the bottom of the selected row. See below:

![Figure 5.2-10 Display the result of AutoSum](image)
5.4 Define Names

In the Kingsoft Spreadsheets, you can name a cell range. You can also name a formula or constant. A name is a meaningful shorthand that makes it easier to understand the purpose of a cell range, formula or constant, which may be difficult to comprehend at first glance.

The following is a list of syntax rules that you need to be aware of when creating and editing names.

- The first character of a name must be a letter or an underscore (_). Remaining characters in the name can be letters, numbers, periods, and underscore characters.
- Names cannot be the same as the cell reference.
- Spaces are not allowed as part of a name. Use the underscore character (_) and period (.) as word separators.
- A name can contain uppercase and lowercase letters. However, Kingsoft Spreadsheets does not distinguish between uppercase and lowercase letters. For example, if you create the name “ABC”, and then create another name “abc” in the same workbook, Kingsoft Spreadsheets will remind you to choose a unique name.

5.4.1 Define Name

Defining the name for selected cells will make it easier to refer to the contents in the cell. To define a cell name, follow the steps below:

1. Select the cells which you want to define.
2. In the Formulas tab, click the Name Manager icon and the Define Name dialogue box will open and show as below:
5.4.2 Create Names

Cell range can be just a cell or multiple cells. These cells can be adjacent or non-adjacent. If you want to define a cell range name, follow the steps below:

1. In the Formula tab, click the Create icon and the Create Names dialogue box will open and show as below:

![Figure 5.4-2 The Create Names dialogue box](image)

2. You can create names in Top row, Left column, Bottom row and Right column.
3. Click OK to complete the operation.

Tips: In this way, you can only name a single row or column separately.

5.4.3 Define Formula Name

The operation steps are as follows:

1. In the Formulas tab, click the Name Manager icon and the Define Name dialogue box will open. See Figure 5.4-1.
2. Input the name of formulas in the Names in workbook text box, click Add, and input the corresponding formulas in the Refer to box.
3. Press OK to complete the operation.
4. If you want to delete the name of the cell, cell range or formula, you can select the corresponding name in the list box and click Delete.

5.4.4 Paste Name

You can paste the name used in the current workbook as formula to the selected cells. Follow the steps below:
(1) Define the name for the selected cell (follow the steps in 5.4-1).
(2) Select the cell where you want to paste the name you have defined.
(3) Click the Paste icon in the Formulas tab and the Paste Name dialogue box will open and show as below:

![Figure 5.4-3 The Paste Name dialogue box](image)

(4) Select the name you have defined in the Paste Name list box.
(5) Click OK to complete the operation. The result is shown as below:

![Figure 5.4-4 The Paste Name result](image)

### 5.5 Calculation

Calculation is the process of computing formulas in the worksheet and then displaying the results as values in the cells which contain the formulas. By default, the spreadsheet will automatically compute formulas in the workbook when you open it.

In Kingsoft Spreadsheets, there are plenty of ways to compute data such as **Automatic Calculation**, 

---

170
Manual Recalculation and Iteration.

To avoid unnecessary calculations, Kingsoft Spreadsheets automatically recalculates formulas only when the cells which contain the formulas change, or the structure of the spreadsheet changes.

5.5.1 Automatic Calculation

If you turn on the automatic calculation mode, when the cells which contain the formulas change, Kingsoft Spreadsheets will recalculate formulas automatically.

The automatic calculation mode is turned on by default in Kingsoft Spreadsheet, but you can also manually turn on this mode. Follow the steps below:

(1) Open the Application menu at the top left corner of the window and click Options at the bottom.

(2) Choose the calculation tab in the Options dialogue box. See below:

![Figure 5.5-1 Automatic Calculation](image)

(3) Select the Automatic option button in the Calculation section.

(4) Click OK to complete the operation.

5.5.2 Manual Recalculaton

When there are complex circular references in a formula, you can turn on the manual calculation mode and recalculate manually. The operation steps are shown as follows:
(1) Open the **Application** menu at the top left corner of the window and click **Options** at the bottom.

(2) Choose the **calculation** tab in the **Options** dialogue box. See below:

![Options Dialogue Box](image)

Figure 5.5-2 Manual Calculation

(3) In the **Calculation** section, select **Manual**.

(4) Press **OK** and finish the **Manual Recalculation** setting.

If you turn on the manual calculation mode, when the cells which contain the formulas change, Kingsoft Spreadsheets won’t recalculate formulas automatically.

- If you need to calculate the current sheet, click the **Calculate Sheet** icon in the **Formulas** tab.
- If you need to calculate the entire workbook, click the **Recalculate Workbook** icon in the **Formulas** tab.

### 5.5.3 Iteration

Kingsoft Spreadsheets provides an iteration calculation function. Iteration refers to repeated recalculation of a worksheet until a specific numeric condition is met. When the number of times of recalculating exceeds the required number, or the results of two calculations meet some specified limit, the calculation will end. To apply the iteration calculation function, follow the steps below:

(1) Open the **Application** menu at the top left corner of the window and click **Options** at the bottom.
(2) Choose the calculation tab in the Options dialogue box. See below:

![Options dialogue box](image)

Figure 5.5-3 Iteration

(3) Select the Iteration check box.

- Enter the number of times of iteration, in the Maximum iterations spinner.
- Enter the error value, in the Maximum change spinner.

(4) Press OK to complete the operation.

### 5.6 Checking

Checking is the process of checking errors or evaluating formula in the worksheet.

- **Evaluate Formula**: Click this icon and the evaluate formula dialog box will open. You can debug a formula by evaluating each part of the formula individually. Choose the cells that you want to evaluate in the Evaluation blank area.

- **Error Checking**: Click this icon to check for common errors that occur when using formulas. You can Choose Error Checking or Circular References in the drop-down list.
6 Data Tab

6.1 Import Data

External data refers to data stored outside of Kingsoft Spreadsheets such as Access, dBASE, SQLServer, and databases created on the Web service. You can click the Import Data icon in the Data tab to import data from a majority of data sources into Kingsoft Spreadsheets. The two ways to get external data will be demonstrated in the following part.

6.1.1 Open data file directly

The first way is to get external data by opening data files directly, which is very easy. The operation steps are shown as follows:

(1) Click the Import Data icon in the Data tab and the Select Data Source dialogue box will open and show as below:

![Select Data Source](image)

Figure 6.1-1 Select Data Source

(2) Select the Open data file directly check box, click the Select Data Source button, and the Open dialogue box will appear where you can select the source data. Click the Open button to return to the Select Data Source dialogue box.

(3) Click Next and The second step: Select table and fields dialogue box will open and show as below:
(4) The usable fields will be listed in the **Available fields** list box. You can use the control button in the middle to add fields into the **Selected fields** list box on the right.

(5) Click **Next** and **The third step: data filtering and sorting** dialogue box will open and show as below:

(6) You can choose sorting by field or in order. You can also set the filtering field, filtering condition and filtering range in the **filtering and sorting** dialogue box. You can enter the query statement directly as well. If you want to perform a more complicated sorting and filtering operation, you can click **Advanced**
Query.

(7) Click Next and **The fourth step: Preview** dialogue box will open and show as below:

![The fourth step: Preview dialogue box](image)

Figure 6.1-4 The fourth step: preview dialogue box

You can preview the worksheet into which you’ve inserted external data in this dialogue box. If you are not satisfied with it, you can click Back to reset until you are satisfied.

(8) Click OK to complete the operation.

### 6.1.2 Use ODBC data source connection guide

The second way is to use the ODBC data source connection guide. The operation steps are shown as follows:

(1) Click the **Import Data** icon in the **Data** tab and the **Select Data Source** dialogue box will open and show as below:
(2) Select the ODBC DSN option button and the Data Connection Wizard dialogue box will open and show as below:

![Figure 6.1-6 Data Connection Wizard](image)

(3) In the ODBC data sources list box, select the preferred data and click OK to go to the Connection tab.

(4) Then you can choose the Search scope and DSN name in the Select data source dialogue box.

(5) Press OK to complete the operation.
6.1.3 Edit OLE DB Query

After you have imported external data into Kingsoft Spreadsheets, you can perform simple queries by using the SQL language. Click Edit Query in the Data tab. See below:

![Edit Query](image)

Figure 6.1-8 Edit Query

The Edit OLE DB Query dialogue box will open where you can perform simple queries. See below:

![Edit OLE DB Query](image)

Figure 6.1-9 Edit OLE DB Query

6.1.4 External Data Range Properties

You can define the Name, Data formatting and layout, and If the number of rows in the data range changes upon refresh of external data source. Click Data Range Properties in the Data tab. The External Data Range Properties dialogue box will open where you can carry out the aforesaid operations. See below:

![External Data Range Properties](image)

Figure 6.1-10 External Data Range Properties

6.1.5 Refresh Data and Refresh All

Refresh Data and Refresh All are designed to refresh data imported from external data source.

Click the Refresh All icon in the Data tab to open the drop-down list. There are two options offered:

Refresh Data: refresh data that you have selected.
Refresh All: refresh all the data you have imported.

## 6.2 Text to Columns

Kingsoft Spreadsheets provides a **Text to Columns** function. It plays an important role in importing text data and performing data storage format conversion. For example, import long digital data and fast data format conversion. To use this function, follow the steps below:

1. Create a blank worksheet. Copy text data from files, such as *.txt and *.csv, and paste it in the A1 cell. See below:

![Figure 6.2-1 Paste the text data](image)

2. Select column A and click the **Text to Columns** icon in the Data tab.

3. In the **Convert Text to Columns Wizard - Step 1 of 3** dialogue box, you can select a suitable file type according to the basic characteristics of the file. In this example we select **Delimited**. Shown as below:
(4) Click Next.

(5) You will see the Convert Text to Columns Wizard - Step 2 of 3 dialogue box, where you can choose further options. Click the Space check box in the Delimiters section. Other settings are all by default. See below:
(6) Click Next button. In the **Convert Text to Columns Wizard - Step 3 of 3** dialogue box, you can set the data format of every column. See below:

(7) Click **Finish** button to complete the operation.
6.3 Duplicates

The Duplicates function provided by Kingsoft Spreadsheets will help you display data that is duplicated in a single row or a single column. It will display a warning when you input duplicated data in a single row or column. In addition, it can delete the unwanted duplicated data directly and keep the original data. The operation steps are shown as follows:

Click the Highlight Duplicates, Reject Insert Duplicates and Remove Duplicates icon in the Data tab.

- Highlight Duplicates: Select one row or one column and choose Set in the drop-down list of Highlight Duplicates. The Highlight Duplicate dialogue box will open to ask your permission to highlight the cells which contain duplicate contents in orange. Then if there is duplicated data in the row or column, the corresponding cells will be highlighted.

- Reject Duplicate Entries: Select one row or one column and choose Reject Duplicate Entries in the Data tab. After selecting it, whenever you insert duplicate data into the row or column, Kingsoft Spreadsheets will automatically display warning information to remind you that the row or column already contains this data. Then you can choose whether or not to insert the data.

- Remove Duplicates: Select one row or one column and choose Remove Duplicates in the Data tab. The Duplicated data in the row or column will be removed and only one will be kept.

6.4 Validation

In order to ensure the accuracy and normative of the input data, Kingsoft Spreadsheets provides the validation function to check data and prevent input error. This function can make your work more efficient. The operation steps are shown as follows:

(1) Select the cell or cell range which you want to validate.

(2) Click the Validation icon in the Data tab. Then the Data Validation dialogue box will open and show as below:
You can set the Validation criteria in the Settings tab.

You can set the display information when you select the cell in the Input Message tab. See below:

You can set the warning information when you input invalid data in the Error Alert tab.

(3) Press OK to complete the operation. The effect is shown below:
6.5 Consolidate

By the consolidation function, data in the cells stored in several worksheets will be combined into one place, helping the user to analyze and manage it more conveniently. For example, a company makes a census about the total sales in 2012 and 2013 and creates a statistics forecast of sales for each year separately, but you want to combine them together in one worksheet. Here you can use the consolidation function.

Here are some terms in the consolidation function:

- **Goal Sheet**: The sheet which stores the consolidated result.
- **Goal Range**: The range which receives the consolidated data.
- **Original Sheets**: The sheets which have been consolidated.
- **Original Ranges**: The ranges which have been consolidated.

Kingsoft Spreadsheets provides two methods to consolidate: by position and by category.

6.5.1 Consolidate by Position

When you want to consolidate data by position, make sure that each range of data has the same layout. That means each range of data to be consolidated must be in the corresponding position on each separate worksheet. For example, in the example workbook, the first two worksheets are 2012 Data and 2013 Data.

We want to consolidate data in the first two worksheets and put the result in the Total Sales worksheet.

The operation steps are as follows:

1. Click the 2012 Data worksheet tab, and input the data. Shown as follows:
(2) Click the **2013 Data** worksheet tab, and input the data. Shown as follows:

![Figure 6.5-2 2013 Data worksheet](image)

(3) Click the **Total Sales** worksheet tab, and input row and column labels. Shown as follows:

![Figure 6.5-3 Total Sales worksheet](image)

(4) Choose the **Total Sales** worksheet as the target worksheet. And select B3:D9 as the target range of data.

(5) Click the **Consolidate** icon in the **Data** tab. The **Consolidate** dialogue box will open and show as below:
In the **Function** box, click **SUM** or the function that you want Kingsoft Spreadsheets to use to consolidate the data.

Enter the range path in the **Reference** box. Or click the source worksheet and select the range of data to be consolidated. Then the range path of the original data will be displayed automatically in the **Reference** box. Click the **2012 Data** tab, and select B3:D9 as the source range. Shown as follows:

(6) Click **Add**. Then the range will be added in the **All References** box.

(7) Repeat the steps mentioned above. Add the range of B3:D9 in **2013 Data** in the **All References** box. Shown as follows:
(8) Press OK. Then the result of consolidation will be displayed in the target worksheet. See below:

![Consolidate dialog box](image)

Figure 6.5-6 Add the 2013 Data cells area

![Consolidated data](image)

Figure 6.5-7 The result of Consolidation

### 6.5.2 Consolidate by Category

If the ranges of data to be consolidated don’t have the same layout, you can use the consolidation by category feature instead of consolidation by position. For example, as you can see in Figure 6.5-1 and 6.5-2, the scores are different in 2012 and 2013.
To consolidate the two worksheets by category, follow the steps below:

(1) Open the **Total Sales** worksheet tab and enter the title. See below:

![Figure 6.5-8 Total Sales worksheet](image)

(2) Select cell A2 and click the **Consolidate** icon in the **Data** tab. Then the **Consolidate** dialogue box will open.

(3) In the **Function** box, select **SUM** or the function that you want Kingsoft Spreadsheets to use to consolidate the data.

(4) Select cell ranges as we mentioned above. In the **2012 Data** worksheet, the selected source range is A2: D9. In the **2013 Data** worksheet, the selected source range is A2: D9. Select **Top row** and **Left column** check boxes in the **Use Labels** section. See below:
(5) Press **OK** to complete the operation. Then the result of consolidation will be displayed in the target worksheet. See below:
6.6 Group

(1) Select the range of data where you want to create a group.

(2) Click the Group icon in the Data tab and the Group dialogue box will open and show as below:

Figure 6.6-1 The Group dialogue box

(3) Select either Rows or Columns option button that you want to group by.

(4) Click OK to complete the operation.

If you want to ungroup the range, do as follows: In the Data tab, open the Ungroup drop-down list and select Clear Outline.

6.7 Subtotal

To use the subtotal function, follow the steps below:

(1) You need to sort the fields that you want to subtotal first so that the fields with the same keyword will gather together. Shown as follows:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>NO</td>
<td>GOODS</td>
<td>PRICE</td>
<td>AMOUNT</td>
</tr>
<tr>
<td>2</td>
<td>A001</td>
<td>Toy</td>
<td>12</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>A002</td>
<td>Toy</td>
<td>15</td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>A003</td>
<td>Toy</td>
<td>17</td>
<td>4</td>
</tr>
<tr>
<td>5</td>
<td>A004</td>
<td>Pen</td>
<td>9</td>
<td>2</td>
</tr>
<tr>
<td>6</td>
<td>A005</td>
<td>Pen</td>
<td>15</td>
<td>3</td>
</tr>
<tr>
<td>7</td>
<td>A006</td>
<td>Pen</td>
<td>12</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>A007</td>
<td>Box</td>
<td>4</td>
<td>5</td>
</tr>
<tr>
<td>9</td>
<td>A008</td>
<td>Box</td>
<td>3</td>
<td>10</td>
</tr>
</tbody>
</table>

Figure 6.7-1 Sort by GOODS

(2) Click the Subtotal icon in the Data tab and the Subtotal dialogue box will pop up.

(3) In the At each change in drop-down list, select the field you want to subtotal.

(4) Select the function you need in the Use function drop-down list in the Subtotal dialogue box.
(5) In the Add subtotal to dialogue box, select the field you want to subtotal.

(6) Select corresponding check box according to your needs to specify the subtotal conditions.

- Replace current subtotals: subtotal according to current sorting.
- Page break between groups: each group should be displayed on separate page.
- Summary below data: put the subtotal result at the end of each group.

(7) Press OK to complete this operation.

### 6.8 Show Detail and Hide Detail

If you can’t see the outline symbols in Kingssoft Spreadsheets, you can click Group in the Data tab. After creating a group, you can perform the following operations:

- If you want to show detail in a group, click the Show Detail icon in the Data tab.
- If you want to hide detail in a group, click the Hide Detail icon in the Data tab.

Tips: you can also click the Show Detail icon and Hide Detail icon on the right side of the worksheet.

### 6.9 Form

Kingssoft Spreadsheets provides a data form function for you to add, delete, and find a series of data more easily in the worksheet.

To use the form data function, follow the steps below:

(1) Select the title of the column in the worksheet and click the Form icon in the Data tab. The Form Data dialogue box will open with the worksheet title as its name. See below:
Figure 6.9-1 The Form function

(2) The data in each row will be displayed together and in separate categories on the left side of the dialogue box.

(3) You can click the **New** button at the right side to add new data in the worksheet.

(4) You can click the **Delete** button to remove the current displayed data from the worksheet.

(5) You can view previous or next row of data by clicking the **Find Prev** and **Find Next** button.

(6) You can click **Criteria** to set the criteria.

(7) Click **Close** to exit the dialogue box.

6.10 What-If Analysis

Kingsoft Spreadsheets provides the what-if analysis function, which includes Goal Seek and Solver Parameters.

6.10.1 Goal Seek

Kingsoft Spreadsheets provides the Goal Seek function to obtain the value in the changing cell when a result value is assumed for a formula. For example, an employee has already known the product sales price is $80 and the product cost is $50, and he wants to know how much is the product sales when the expected total profit reaches $15000.

To use this function, follow the steps below:
(1) Create a worksheet containing the product sales information. The value in B3 is unknown and no need to enter data in it. Enter the formula “=(B1-B2)*B3” in B4.

(2) Click the **What-If Analysis** icon in the **Data** tab and choose **Goal Seek** in the drop-down list. The **Goal Seek** dialogue box will open and show as below:

![Goal Seek dialogue box](image)

Figure 6.10-1 The Goal Seek dialogue box

(3) Select cell B4 in the **Set cell** section, enter 15000 in the **To value** enter box, and select B3 in the **By changing cell** section.

(4) Click **OK** to complete the operation. You can see the result as shown below:

![Goal Seek Status](image)

Figure 6.10-2 Goal Seek Status

(5) Click **OK** to preserve the result.

### 6.10.2 Solver Parameters

Simply speaking, Solver Parameters can help you forecast the problem which contains more than one variable. For example, the shopkeeper wants to know which kinds of pens he should sell and the potential revenue. Assuming that there are three kinds of pens, namely gel pen, pen, and ball pen, and their prices are $1, $2, and $2.5.
To use this function, follow the steps below:

(1) Create a worksheet containing the product sales information. See below:

![Worksheet containing the information](image)

Figure 6.10-3 Worksheet containing the information

(2) The target cell, here G4, is achieved by adding the three variable cells, namely D6, D10, D14. Whereas the value in the three variable cells are achieved by multiply the price with the volume of sales of each kinds of pen separately. The constrains area contains limiting conditions. You can list them down to help you organize your thoughts.

(3) In the Data tab, select the Solver Parameters in the What-If Analysis drop-down list. The Solver Parameters dialogue box will open and show as below:

![Set the Solver Parameters dialogue box](image)

Figure 6.10-4 Set the Solver Parameters dialogue box

(4) Select the target cell in the Set Objective section. Here we choose cell G4.

(5) Choose Max in the To section to get the possible maximum revenue.

(6) Select the changing cells in the By Changing Variable Cells section. Here we select cell D5, D9, and D13.

(7) Click Add to add constraints. The Add Constraint dialogue box will open and show as below:
The three constraints in Figure 6.10-4 mean that first, the total sales volume should be less than or equal to the maximum sales volume of all pens, here 500; second, the sales volume of pen and ball pen should be less than or equal to the maximum sales volume of pen and ball pen, here 350; third, the sales volume of ball pen should be less than or equal to the maximum sales volume of ball pen, here 125.

(9) Choose the Simplex LP option as the solving method.

(10) Click Solve to complete the operation.

(11) Click OK to solve the results. See below:

The solver results will be like below:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can see the possible maximum revenue is $912.5. At this point, the shopkeeper have to sell 150 gel pen, 225 pen, and 125 ball pen.
6.11 Pivot Table

Kingsoft Spreadsheets provides the pivot table function, which makes it easy to arrange and summarize complicated data on details. To use this function, follow the steps below:

(1) Create a worksheet containing the product sales information. See below:

![Figure 6.11-1 Worksheet containing the information](image)

(2) Click the **Pivot Table** icon in the **Data** tab and the **Create PivotTable** dialog box will open and show as below:
(3) Select a range of cell that you want to analysis or you can select **Use external data source** in the **Choose the data that you want to analyze** section. Here we choose cell A1:C21.
(4) Then you need to choose where you want the PivotTable report to be placed. There are two choices: New worksheet and Existing worksheet. Here we choose New worksheet and click the OK button.

![Create PivotTable](image)

Figure 6.11-4 Choose the new worksheet

(5) A new worksheet will open. Here we add the **Product** to column area; add the **Customer** to row area; and add the **Total Price** to data area. See below:
You can contract this operation by manually drag fields onto PivotTable area. See below:
(6) The effect as below:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sum of Total</td>
<td>Consumer</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Price</td>
<td>FuXin</td>
<td>LaoLiu</td>
<td>LiSi</td>
<td>WangWu</td>
<td>ZhangSan</td>
<td>Grand Total</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>1086</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td></td>
<td>684</td>
<td></td>
<td>912</td>
<td>1596</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>668</td>
<td>890</td>
<td></td>
<td></td>
<td>1558</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>4</td>
<td></td>
<td></td>
<td>1374</td>
<td></td>
<td>1374</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>5</td>
<td></td>
<td></td>
<td>905</td>
<td></td>
<td>905</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td>224</td>
<td></td>
<td>224</td>
</tr>
<tr>
<td>9</td>
<td>Grand Total</td>
<td>1754</td>
<td>1114</td>
<td>1590</td>
<td>1374</td>
<td>1152</td>
<td>6984</td>
</tr>
</tbody>
</table>

Figure 6.11-7 The final effect

Tips: The PivotTable tab will appear in the menu bar. See below:

These function are as follow:

- **Modify PivotTable**: Change PivotTable data source and reset its display location.
- **Refresh Data**: Update the information from the data source in the workbook.
- **Sort**: Set the auto sort option of the PivotTable field.
- **Hide**: Hide the PivotTable fields in page, row, column area or items in the fields.
- **Order**: Move the row or column area of a PivotTable to the top or bottom.
- **Delete**: Delete the currently selected PivotTable.
- **ShowDetail**: Show all items of the active field.
- **HideDetail**: Hide all items of the active field.
- **Repeat All Item Labels**: Show all parent item labels.
- **Do Not Repeat All Item Labels**: Show only one of the duplicate parent item labels.
7 Review Tab

7.1 Check Spelling

Kingssoft Spreadsheets provides a Check Spelling function to proofread the text in the worksheet according to the values you have set and the dictionaries which you have choose as the check spelling criteria.

To spell check the worksheet, follow the steps below:

(1) Open the worksheet which you want to spell check.

(2) Click the Spell Check icon in the Review tab, or select the Spell Check option in the drop-down list. See below:

![Figure 7.1-1 The Check Spelling drop-down list]

(3) Then Kingssoft Spreadsheets will automatically spell check the worksheet and remind you when the spell check has been completed. See below:

![Figure 7.1-2 Complete the check spelling]

You can also set language for the spell check, follow the steps below:

(1) Choose the Set Language option in the Check Spelling drop-down list. See Figure 8.1-1.

(2) The Set Language dialogue box will open and show as below:
(3) Choose the preferred language in the Available Languages list box.

(4) You can click Set Default to set the chosen language as the default language for spell check.

(5) Click Close to complete the operation.

To set the dictionaries for check spelling, follow the steps below:

(1) Open the application menu at the top left corner of the screen. Click Options at the right bottom.

(2) Open the Spell Check tab in the Options dialogue box. See below:
(3) In the Spell Check section, you can select Always suggest corrections, Ignore words in uppercase, and Ignore words with numbers check box according to your needs.

(4) In the Custom dictionary section, you can add new words or delete words in the current dictionary by the Modify button.

(5) Click the New button to select the new custom dictionary in the corresponding dialogue box.

(6) Click the Add button to add dictionary files.

(7) Click the Remove button and choose to remove the selected dictionary either from list or from disk.

(8) You can set the selected dictionary as default by the Set as Default button.

(9) Click OK to complete the operation.

7.2 Comment

Just like Kingsoft Writer, Kingsoft Spreadsheets allows you to insert comments as well. This function makes it very convenient for you to do business without papers.

In Kingsoft Spreadsheets, you can insert comments when you want to illustrate the cell(s). After adding a comment, there will be a little red triangle shown at the top right corner of the cell. The content will appear
automatically when you move the mouse to the cell.

### 7.2.1 Create Comment

If you want to set up a reminder for a cell or a cell range, you can add comments. The steps are shown as follows:

1. Select the cell or cell range to which you want to add comment.
2. Click the **New Comment** icon in the **Review** tab. Or right-click and select **Insert Comment** in the context menu.
3. Input the content of comment in the **Comment** dialogue box.
4. After inputting the comment, press **OK** to complete the operation.

### 7.2.2 Edit Comment

You can edit comments that you have created in the Kingsoft Spreadsheets. The operation steps are as follows:

1. Select the cell or cell range you want to edit comment.
2. Click the **Edit Comment** icon in the **Review** tab. Or right-click and choose **Edit Comment** in the context menu.
3. Then the **Comment** dialogue box will pop up where you can edit the comment.
4. After editing the comment, press **OK** to complete the operation.

### 7.2.3 Delete Comment

In Kingsoft Spreadsheets, you can either delete the comment of a single cell or delete all the comments in the worksheet simultaneously. The operation steps are as follows:

1. To delete the comment, you need to select it first.
2. Click the **Delete Comment** icon in the **Review** tab. When the little red triangle disappears, it means the comment has been deleted.

If you want to delete all the comments in the worksheet, follow the steps below:

1. Press `<Ctrl+A>` to select all the comments.
2. Open the **Home** tab and click the **Format** icon.
3. Choose **Comments** in the **Clear** drop-down list. Then you can delete all the comments.
7.3 Lock Cell

There are three ways to protect a specified cell:

- Click the Lock Cell icon in the Review tab.
- Press \(<\text{Ctrl}+\text{A}>\) to select the whole worksheet. In the Home tab, click the Format icon and select Lock Cell in the Format drop-down list.
- Select the whole worksheet, right-click and select Format Cells in the context menu. In the Format Cells dialogue box, open the Protection tab and select or deselect the Locked check box. Then you can lock the cells or unlock the cells.

**Tips:** The worksheet protection only works on locked cells.

7.4 Protect sheet

In order to protect your data, Kingsoft Spreadsheets allows you to set a password for the worksheet or workbook by which you can prevent unauthorized users to modify the worksheet or workbook.

You can protect a worksheet by the Protect Sheet function provided by Kingsoft Spreadsheets. Moreover, you can protect cell range, decide cell ranges can be filled or not, and lock the corresponding content to avoid covering important data when filling.

This function can be used to make tables which need to be filled, or protect important data from being modified. The operation steps are shown as follows:

(1) Click the Protect Sheet icon in the Review tab. The Protect Sheet dialogue box will open and show as below:
(2) By default, only Select locked cells and Select unlocked cells are checked. If you want some other protection, such as Format cells, you can select the check box to activate it.

(3) Enter the password in the Password input box.

(4) Click OK to complete the operation.

Tips: This protection for worksheet only works on locked cells. After setting the protection, all you have to do is to save the file and the setting will go into effect.

If you want to cancel the worksheet protection, click Unprotect Sheet in the Review tab. Or you can try the other way: Select Unprotect Sheet in the Format drop-down list in the Home tab.

Enter the password you have set and the entire worksheet will be as it was before you locked it.

### 7.5 Protect Workbook

Workbook protection can prevent altering the structure of the workbook, which includes deleting, moving, hiding, unhiding, and renaming the worksheet. You cannot insert a new worksheet or move and adjust the window either when the workbook has been protected.

The operation steps are shown as follows:

(1) Select the workbook you want to protect.

(2) Click Protect Workbook in the Review tab. Then the Protect Workbook dialogue box will open and shown as below:

![Figure 7.5-1 The Protect Workbook dialogue box](image)

(3) Input the password, and then press OK.

(4) If you want to remove the protection on a workbook, click the Unprotect Workbook icon in the Review tab, and then input the password to cancel the protection.

### 7.6 Share Workbook

If you want multiple users to edit a workbook at the same time, you can share your workbook, which means to put the workbook under a shared directory—a web server for example. Then others can access
the shared workbook through the Internet. This feature makes it more effective and easier for multiple users to edit a workbook simultaneously. The operation steps are as follows:

(1) Select the workbook you want to share.

(2) Click the **Share Workbook** icon in the **Review** tab. The **Share Workbook** dialogue box pops up.

![Share Workbook Dialogue Box](image)

Figure 7.6-1 Set for sharing workbook

(3) Click the check box in front of **Allow changes by more than one user at the same time. This also allows workbook merging.**

(4) Click **OK** and the **Save As** dialogue box will open. Choose **Kingsoft Spreadsheets Files (*.et)** as the **Save as Type**. Input the **File Name** and press **Save** to complete the operation.

(5) After sharing the workbook, the file name on the title bar will be added with “(shared)”.

(6) After sharing the workbook, you can protect or unprotect it by clicking the **Protect Shared Workbook** and **Unprotect Shared Workbook** icon in the **Review** tab.

**Tips:** If you created a new file, before you can confirm to share it, the system will warn you to save it first. After you have saved the file, it will be shared automatically.
7.7 Protect and Share Workbook

If the workbook has already been shared and you wish to protect the sharing of track changes by entering a password, the steps are shown as follows:

(1) Select the workbook you want to protect.
(2) Click Protect and Share Workbook in the Review tab. Then the Protect and Share Workbook dialogue box will open and show as below:

![Protect and Share Workbook dialogue box](image)

Figure 7.7-1 Protect and Share Workbook dialogue box

(3) Enter the Password and press OK to complete the operation.

7.8 Allow Users to Edit Ranges

Sometimes you may want others to make changes only to part of the data in the worksheet, but keep the rest of it locked. To achieve this, follow the steps below:

(1) Click the Allow Users to Edit Ranges icon in the Review tab. The Allow Users to Edit Ranges dialogue box will open and show as below:
(2) Click **New**.

(3) In the **New Range** dialogue box, set the title in the **Title** enter box, select the cell range you wish to allow others to edit in the **Refer to cells** section and enter the range password in the **Range Password** section.

(4) Click **OK** to return to the **Allow Users to Edit Ranges** dialogue box.

(5) Click the **Protect Sheet** button in the lower left corner of the dialogue box.

(6) Reenter the range password you have set in step 3 twice to protect the selected range.

(7) Now the selected range has been protected and users have to enter the password to make changes to it.
7.9 Track Changes

You can use the **Track Changes** function if you want to track the changes made in your worksheet. Each reviewer who inserts or deletes data will be recorded when the **Track Changes** function is turned on. Kingsoft Spreadsheets provides the **Highlight Changes** function in order to distinguish changes made by different users. So when you open the worksheet, you can see all of the changes at once. The operation steps are shown as follows:

1. Click the **Track Changes** icon in the **Review** tab to open the drop-down list and select the **Highlight Changes** option. The **Highlight Changes** dialogue box will open and show as below:

   ![Figure 7.9-1 The Highlight Changes dialogue box](image)

2. Select the **Show track changes description** check box and set criteria for changes, namely **When**, **Who**, and **Where** in the **Highlight which changes** section.

3. Press **OK** to complete the operation.

4. Then you can make changes in the worksheet, and press **Enter** to finish. You will notice that the data that has been changed will be marked up.

**Tips:** The **Track Changes** function can only be used in the shared workbook.

7.10 Thesaurus

You can use the **Thesaurus** function if you want to find for the other words with a similar meaning to the word you have selected, follow the steps below:

1. Select the word that you want to find for the other words with a similar meaning.

2. Click the **Thesaurus** icon in the **Review** tab and the **Thesaurus dialogue box** will open. See below:
(3) You can select your preferred language in the **Language** section.

(4) You will get a range of words that have similar meaning with the one you have selected. Then choose a word you need.

(5) Click the **Replace** button to complete the operation.

(6) Click the **Cancel** button to exit the dialogue box.

### 8 View Tab

#### 8.1 View Mode

Kingsoft Spreadsheets provides five different workbook view modes: **Normal**, **Page Break Preview**, **FullScreen**, and **Reading Layout**. You can select different view mode to suit your needs.

##### 8.1.1 Normal

Normal view is the default view of Kingsoft Spreadsheets. You can edit the content, format, and layout directly in the normal view. If currently you are not in the normal view, you can return to it by clicking the **Normal View** icon in the **View** tab.
8.1.2 Page Break Preview

If you are working in a long document and want to break it into many pages, you can insert a page break in the worksheet. After the insertion, you can preview the worksheet in the page break preview mode.

There are two ways to insert a page break: automatic and manual.

8.1.2.1 Automatic Page Break

In the Page Setup dialogue box (see 4.1.6), select the Page tab to set suitable paper size for printing. If you set values in the Adjust to section, the system will ignore all the page breaks you have manually set.

After setting the values in Adjust to section, click the Page Break Preview icon in the View tab and the worksheet will automatically be separated into pages you have set.

8.1.2.2 Manual Page Break

If you don’t set values in the Adjust to section of the Page tab, the worksheet will be separated into several pages according to your specified width when you click Page Break Preview in the View tab. At this moment, you can put the pointer on the horizontal or vertical page break line. See below:

By dragging the mouse, you can move the horizontal and vertical page break line freely, and you can enlarge the width of separated pages and increase the number of separated pages by doing that.

8.1.3 Full Screen

Click the Full Screen icon in the View tab, the worksheet will be displayed in full screen with all the tool bars hidde. Click the Close button at the top right corner of the screen, or press <Esc> on the keyboard to exit the full screen mode.
8.1.4 Reading Layout

We often have to deal with spreadsheets with a large number of rows and columns. It is inevitable that lines and columns will be misread when we check for formulas or data. As for this, Kingsoft Spreadsheets provides Reading Layout which makes it easier to check the data.

To use the reading layout mode, follow the steps below:

(1) Click the Reading Layout icon in the View tab to enter into the Reading Layout mode. See below:

```
<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2012 Data</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Name</td>
<td>Score 1</td>
<td>Score 2</td>
<td>Score 3</td>
</tr>
<tr>
<td>3</td>
<td>NB 001</td>
<td>100</td>
<td>99</td>
<td>98</td>
</tr>
<tr>
<td>4</td>
<td>NB 002</td>
<td>97</td>
<td>96</td>
<td>90</td>
</tr>
<tr>
<td>5</td>
<td>NB 003</td>
<td>99</td>
<td>97</td>
<td>95</td>
</tr>
<tr>
<td>6</td>
<td>NB 004</td>
<td>94</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td>7</td>
<td>NB 005</td>
<td>98</td>
<td>92</td>
<td>99</td>
</tr>
<tr>
<td>8</td>
<td>NB 006</td>
<td>96</td>
<td>97</td>
<td>98</td>
</tr>
<tr>
<td>9</td>
<td>NB 007</td>
<td>99</td>
<td>100</td>
<td>94</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

Figure 8.1-2 View the data in the Reading Layout mode

(2) Click a cell (or cell range) and Kingsoft Spreadsheets will highlight the line and column of the current cell.

(3) The default color for this mode is a light yellow as shown above and you can choose the preferred color in the Reading Layout drop-down list. See below:

```
[Image: Reading Layout mode selection]
```

Figure 8.1-3 Choose color for the Reading Layout mode

(4) You can re-click Reading Layout in the View tab to exit the Reading Layout mode. Then you can get back to the normal view.

In addition, reading layout belongs to documents level. If you open a number of documents at the same time, all the documents need to enter in the reading layout mode to set or cancel the setting.
8.2 View Check Boxes

There are six check boxes listed in the View tab by which you can hide or display certain items in the worksheet. See below:

![Check boxes in the View tab](image)

Figure 8.2-1 Check boxes in the View tab

The function of these check boxes are shown as follows:

- **Formula Bar**: Select or deselect this check box to show or hide the formula bar in the worksheet.
- **View Gridlines**: Select or deselect this check box to show or hide the gridlines in the worksheet.
- **View Headings**: Select or deselect this check box to show or hide the row and column headings in the worksheet.
- **Task Window**: Select or deselect this check box to show or hide the task window at the right side of the worksheet.
- **Print Gridlines**: Select this check box to print gridlines in the worksheet.
- **Print Headings**: Select this check box to print the row and column headings in the worksheet.

8.3 Zoom

To specify the zoom size of the worksheet, follow the steps below:

1. Click the **Zoom** icon in the View tab. The **Zoom** dialogue box will open and show as below:

![The Zoom dialogue box](image)

Figure 8.3-1 The Zoom dialogue box

2. Choose the preferred proportion in the **Magnification** section.
3. You can choose the **Fit Selection** option to let Kingsoft Spreadsheets automatically choose for you.
4. You can also enter the proportion in the **Custom** enter box.

214
(5) Click **OK** to complete the operation.

## 8.4 Freeze

Usually, we edit a large number of rows and columns in Spreadsheets. But when scrolling, it is inconvenient to keep the row or column label shown all the time. Sometimes we need to check the labels for the data in some rows or columns. We don’t want the row or column to move, for which it is very helpful to freeze the window.

The steps to freeze the window are shown as follows:

1. In the worksheet, select the leftmost cell of the cell range you want to freeze.

   ![Figure 8.4-1 Select the cell](image)

2. Click the **Freeze** icon in the **View** tab.

3. There will be a line above the selected cell range. Drag the scroll bar and the rows and columns in the frozen range won’t scroll. The frozen range is always in the top and left-most position. See below:
(4) Click **Unfreeze** in the **View** tab and you can unfreeze the window.

### 8.5 Window Functions

Kingsoft Spreadsheets provides three window functions in the **View** tab. See below:

![Window functions](image)

The window functions are shown as follows:

- **New Window**: To open a new window containing the contents of the current worksheet.
- **Arrange All**: When there are more than two opened worksheets, you can view them horizontally, vertically, or in cascade by choosing the corresponding option in the drop-down list. Double click the window head to return to the normal view mode.
- **Split**: To split worksheet to multiple re-sizable panes containing views of the current worksheet. Click this icon again to cancel the operation.

### 8.6 Mode

(1) **Eye Protection Mode**: select the **Eye Protection Mode** icon in the **View** tab
to enable Eye Protection Mode to relieve your eye fatigue and click this icon again to exit this mode.

(2) **Night Mode**: select the **Night Mode** icon in the **View** tab and to switch to Night Mode to protect your eye sight and click this icon again to exit this mode.

**Tips:**

you can click this icon on the bottom right corner of the screen to Open/Close Eye Protection Mode or Night Mode.

## 9 Developer Tab

### 9.1 Macros

To set macros in Kingsoft Spreadsheets, follow the steps below:

(1) Click the **Macros** icon in the **Developer** tab, or in the **View** tab. The **Macros** dialogue box will open and show as below:

![Figure 9.1-1 The Macros dialogue box](image)

(2) Enter the macro name in the **Macro name** enter box.
(3) Select the range you want to apply the macro in the **Macro in** drop-down list.

(4) Add description for this macro in the **Description** enter box.

The functions of the buttons at the right side are shown as follows:

- **Run**: Click to run the current macro.
- **Edit**: Click to edit the macro in Microsoft Visual Basic.
- **Delete**: Click to delete the macro.
- **Options**: Click to add shortcut key for the macro.

(5) Click **Cancel** to exit.

**9.2 Security**

In Kingsoft Spreadsheets, you can set security level for the macros, follow the steps below:

(1) Click the **Security** icon in the **Developer** tab. The Security dialogue box will open and show as below:

![Security Level tab](image)

(2) In the **Security Level** tab, choose **Very High**, **High**, **Medium**, and **Low** according to your needs.
(3) Click **OK** to complete the operation.

## 9.3 Other Functions

- **Visual Basic Editor**: Click to open the Visual Basic Editor and edit the macros there.
- **Add-Ins**: Manage the Add-Ins available for use with this file.
- **COM Add-Ins**: Add or delete the available COM Add-Ins.
- **Design Mode**: Enter design mode to edit control’s name and functions.
- **Control Properties**: View and modify properties for the selected control.
- **View Code**: View and modify the code for the selected control in the Visual Basic Editor.

To add objects in the worksheet, you can click the corresponding icon in the **Developer** tab. See below:

![Add objects icons](image)

**Figure 9.3-1 Add objects icons**

You can add check box, text box, command button, option button, list box, combo box, toggle button, spin button, scroll bar, label, image, and more controls in the worksheet by the corresponding icon.

When the cursor turn into a cross, hold and drag it to insert the object in the worksheet. After the object was drawn, double click it to edit it in the Microsoft Visual Basic.

## 10 Special Feature

The functions offered in the last tab-the **Special Features** tab are as follows:

1. **File Roaming**: Files are automatically shared to WPS Office Cloud and to your PC and mobile devices using WPS Office.

2. **Export to PDF**: Click the **Export to PDF** icon in the **Special Feature** tab and the **Export to PDF File** dialogue box will open. See below:
Figure 10-1 Export to PDF File dialogue box

- **Save to**: You can choose the place where the PDF file is saved.
- **Export range**: You can choose the Active Sheet or the Entire Sheet as export range.
- **Export options**: You can choose Summary information, Hyperlink or New Comment as export options.